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1 Preface 

This tutorial provides all information required when you start using PowerSI.  

This Preface has the following sections: 

• Overview 

• Who Should Read This Tutorial 

• Additional Documentation 

• Customer Support Information 

1.1 Overview 
This tutorial has the following chapters.  
Chapter Page 
Introduction 6 
Project 1 Impedance of Power Delivery System 10 
Project 2 Modeling and Transient Simulation 21 
Project 3 Decoupling Capacitors Placement 47 
Project 4 IR Drop Analysis for Power Delivery Systems 74 

1.2 Who Should Read This Tutorial 
PowerSI is intended to be used by engineers and researchers who work in the areas of design, 
modeling, and simulation of integrated circuits, chip carriers, and printed circuit boards (PCB). 
Users should have at least an entry-level experience in SPICE circuit simulations, and be aware of 
power and signal integrity issues in high-speed or high-frequency electronic systems. 

1.3 Additional Documentation 
For more information about PowerSI, see the following documents: 
• PowerSI Getting Started Guide 
• PowerSI Tutorial  
• PowerSI_Chip_Cosimulation_Tutorial 
• Q&A 
• SPD_File_Format_RG 
• PowerSI User’s Guide 
• Translators User’s Guide 

1.4 How to Contact Technical Support  
If you have questions about PowerSI, contact the Cadence Online Support. 
 

http://support.cadence.com/
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2 Introduction 

This chapter introduces PowerSI briefly and other related information.  
This chapter covers the following sections:  
• Software Overview 
• PowerSI Workplace 
• PowerSI and SPEED2000 
• PowerSI and Broadband SPICE 
• PowerSI Workflow 

2.1 Software Overview 

2.1.1 What’s PowerSI 
PowerSI is a new generation simulation tool to analyze electrical integrated-circuit (IC) packages 
and printed-circuit boards (PCB) for power and signal integrity.  
It can provide full-wave analysis results quickly and accurately. This feature allows it to overcome 
tough high-speed design issues in power, ground, and signal integrity.  
PowerSI uses frequency domain effectively in analysis of package and board performance due to 
its electromagnetic field computation engine.  

2.1.2 Applications  
PowerSI can be used for analysis and design of electronic packages including chip carriers and 
PCBs. It is particularly effective for the following applications: 
• Pre-layout and post-layout electrical analysis for entire packages and boards. 
• Package and board resonance identification.  
• Frequency-dependent impedances extraction for power ground systems.  
• Decoupling capacitor placement optimization.  
• Frequency-dependent S, Z, and Y network parameters determination.  
• Signal return path discontinuities analysis. 
• Electromagnetic coupling evaluation for planes, traces, and vias. 
• What-if comparisons to optimize electrical performance. 

2.2 PowerSI Workplace 
This illustration indicates major parts of the workplace when you open a file in PowerSI. See 
PowerSI User’s Guide for detailed information about menus, toolbars, and workflow pane.  
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A. Menu bar  B. Toolbars  C. Workflow pane   
D. Show area  E. Output/Folder Browser/TCL Reader pane   
F. Layer Selection, Net Manager, or Circuit/Linkage Manager 

2.3 PowerSI and SPEED2000 
PowerSI and SPEED2000 are complementary signal and power integrity. They share the same 
patented technologies of efficient full-wave analysis of complex packages and PCBs.  
PowerSI and SPEED2000 use unique field computation methodologies to perform analysis for an 
entire package or board with full-wave accuracy, allowing fine numerical meshes for the modeling 
of detailed structures, such as cuts and slots in planes, multiple power and ground layers, and any 
number of vias and traces.  
PowerSI specifically focuses on frequency domain analysis while SPEED2000 specializes in time 
domain. PowerSI and SPEED2000 share the same data file and have a very similar user interface 
environment.  

2.4 PowerSI and Broadband SPICE 
The Broadband SPICE generates HSPICE and general SPICE-compatible equivalent circuit 
models for a passive N-port network characterized by its S, Z, and Y parameters. 
The computation of N-port parameters for the package and board used by PowerSI can help users 
acquire accurate SPICE-compatible equivalent circuits. And these circuits can be used for time-
domain simulations with other passive and active components, such as transistor level driver 
models in SPICE-like circuit simulators. 
The second project in this tutorial describes the PowerSI-Broadband SPICE flow for I/O 
modeling and transient simulation. See Chapter 3 Project 2 Modeling and Transient Simulation. 
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2.5 PowerSI Workflow 
PowerSI has an integrated environment for graphically editing physical structures, and creating 
and editing circuits. The environment can build packages or boards for pre-layout analysis.  
Many translators are developed to convert data files from other vendors to Sigrity’s data file .spd. 
So you may use any data files generated under other tool environments to do the post-layout 
analysis of packages and boards. 
PowerSI has three simulation modes: Extraction Mode, Spatial Mode, and Resonance Mode. 

2.5.1 Extraction Mode 
In the extraction mode, PowerSI can easily and conveniently extract S, Z, and Y parameters of 
multiple ports specified- for package and board structures, such as a power delivery system. 
The following figure shows a typical workflow of PowerSI in the extraction mode: 

 

2.5.2 Spatial Mode 
In the spatial mode, PowerSI can do AC analysis for circuits with many sources and obtain the 
following results:  
• Spatial solutions of voltage distribution across planes. 
• Voltage and currents in circuit components. 
• Voltage and currents in physical structures such as traces and vias. 
The following figure shows a typical flow of PowerSI in the spatial mode: 



PowerSI Tutorial 
 

January 2014                                                      9                                                  Product Version 16.6 

 

2.5.3 Resonance Mode 
The resonance mode solver computes and displays all resonant modes between predefined 
frequency ranges. User can also specify the number of resonant modes directly. 
PowerSI outputs a table which lists complex resonant frequencies and Q factors in the resonance 
mode. 
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3 Project 1 Impedance of Power Delivery 
System 

This chapter describes how to use PowerSI to simulate the frequency-dependent power-ground 
impedance profiles at specified power and ground pin locations.  
This chapter takes two files psi_brd_demoshort.spd and psi_brd_demodecaps.spd as examples to 
demonstrate how to use PowerSI. The two files are within the installation directory.  
The chapter has the following sections:  
• About the Examples  
• Power Ground System Without Decoupling Capacitors  
• Power Ground System With Decoupling Capacitors 

3.1 About the Examples 
Both psi_brd_demoshort.spd and psi_brd_demodecaps.spd have the same board with six 
metal layers including one power plane and one ground plane.   
For psi_brd_demodecaps.spd, the board has decoupling capacitors mounted. The board 
dimensions are about 10 x 6 cm with FR4 dielectric material.  

3.2 Power Ground System Without Decoupling Capacitors 
This section takes psi_brd_demoshort.spd as an example to explain how to use PowerSI.  
This section has the following topics:  
• Start PowerSI and Load a File 
• View Port Setup 
• Set up Simulation Frequencies 
• Run a Simulation 
• View Simulation Report 

3.2.1 Start PowerSI and Load a File 
Follow these steps to start PowerSI and load a file:  
1. Launch PowerSI.  
2. Select Mode > Extraction Mode. 

Extraction Mode is selected by default when PowerSI is launched. You can double-check to 
ensure the mode is correctly enabled. 

3. Select File > Open…. 
The Open dialog box opens.  
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4. Double-click psi_brd_demoshort.spd. 

or  
Choose the file and click Open.  
A 2D layer view displays.  

 
In this example, the circuit connects to an edge connector at the lower right corner of the 
board. The circuit has only one 0.01 Ω resistor which short circuits the power and ground 
pins of the edge connector. 
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3.2.2 View Port Setup 
Follow these steps to check the setup:  
1. Select Setup > Port…. 

The Port setup dialog box opens.  

 
This example has one predefined port.  
• The port positive terminal is connected to the package node — Node184!!48::VCC.  

• The port negative terminal is connected to the package node — Node201!!50::GND. 

2. Select Port 1 and click Find & Fit.  
The port area appears in the center of the layer view window. 

 
3. Click the Fit button  on the Main Toolbar to return to the overall view. 
4. Close the Port dialog box. 
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3.2.3 Set up Simulation Frequencies 
Follow these steps to set up simulation frequencies:  
1. Select Setup > Simulating Frequencies….  

The Frequency Ranges dialog box opens. 

 
2. Change the following parameters in this window:  

• Starting Freq. to 10 MHz (or 0.01 GHz) 
• Ending Freq. to 2.0 GHz 
• Sweeping Mode to Adaptive from the drop-down menu.  

3. Click OK to finish the setup. 

3.2.4 Run a Simulation 
Follow these steps to perform a simulation:  
1. Click the Start Simulation button  to start the frequency sweeping simulation for the 

network parameters at the port location.  
An S-parameter displays first as follows.  

 
The Output window shows the process status during the simulation.  
The Status bar shows Computing completed after the simulation is done.  
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2. Click and choose the Z (impedance) parameter from the drop-down menu. 

 
A Z-parameter curve displays as follows. 

 
3. Right-click the plot to open a pop-up menu.  

 
4. Select Save Simulation Result.  

The Save Curves dialog box opens. 
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5. Select Touchstone format from the Network parameter file format drop-down menu and 

rename the file to psi_brd_demoshort.S1P. 
6. Click OK.  
7. Close the project without saving it.  
 

Tip! 
Double-click a curve to show the Curve Pattern Property box.  
You can change Style, Pattern, Width, and Mark for the curve.  
See 2.3.4 Run a Simulation for the details. 

3.2.5 View Simulation Report 
You can view the simulation report after running a simulation.  
Follow these steps to open the simulation report window:  

1. Click  to return to the Layer View window.  
2. Select File > Report.  

 
The Simulation Report Setting window opens. 
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NOTE! 
You can select Tools > Options > Edit Options… > Simulation (Basic) > 
Report to open the window, too.  

3. Click OK directly, or set up the Simulation Report Setting.  
The Simulation Report window appears as shown below:  

 
You can see from the window that the Simulation Report includes:  
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 General information: Spd file name and location, Board stackup, and Layout top 
and button layer views. 

 Simulation setup: Net enabled for simulation, Circuit enabled for simulation, Port 
setup, and Frequency setup. 

 Results: Simulation resources, Topology and port topology block diagrams, and 
Simulation results curve displays. 

 

NOTE! 
You may need to select Window > Simulation Report to show the 
Simulation Report window. 

3.3 Power Ground System With Decoupling Capacitors 
This section takes the file psi_brd_demodecaps.spd as an example to describe how to use 
PowerSI.  
This section has the following topics:  
• Load a File 
• View Setup  
• Set up Simulation Frequencies 
• Run a Simulation 

3.3.1 Load a File 
Follow steps in 3.2.1 Start PowerSI and Load a File to load the file psi_brd_demodecaps.spd.  

3.3.2 View Setup 
Follow these steps to check the setup:  
1. Select Setup > Circuit/Linkage Manager. 

 
The Circuit/Linkage Manager window opens in the right side of the main window. 
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This example contains six decoupling capacitors connected through the power ground to the 
supply planes at the side edges of the board.  
 

NOTE! 
For how to set up decoupling capacitors, please refer to Working with 
Circuits in the document SPD_Layout_UG. 

 
Ensure that you have clicked to enable Show Circuit in the Layer Selection window as 
follows:  

 
The file psi_brd_demodecaps.spd has the same mesh settings (90 x 50) and port specifications as 
the file psi_brd_demoshort.spd. 

3.3.3 Set up Simulation Frequencies 
Follow the steps in 3.2.3 Set up Simulation Frequencies to set up the simulation frequencies. 
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3.3.4 Run a Simulation 
Follow these steps to perform a simulation:  
1. Click the Start Simulation button  to start the simulation.  
2. Change the display to a Z-parameter curve. See 2.2.4 Run a Simulation for details. 

 
3. Double-click the curve to open the Curve Pattern Property dialog box.  

  
Change the curve color to red. You can also change Style, Pattern, Width, and Mark for 
the curve. 

4. Right-click in the blank space of the Network Parameters pane to open a pop-up menu.  

 
5. Select Load to load the psi_brd_demoshort.S1P file which is saved during operation on 

psi_brd_demoshort.spd.  
6. Compare the power ground performance with and without decoupling capacitors. 



PowerSI Tutorial 
 

January 2014                                                      20                                                  Product Version 16.6 

 
The loaded curve overlaps with the present one. So the difference is clear.  

7. Close the project without saving it. 
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4 Project 2 Modeling and Transient 
Simulation 

This chapter describes how to use PowerSI and Broadband SPICE in I/O modeling and transient 
analysis.  
The chapter contains the following sections: 
• Overview 
• Constructing a Package 
• Specifying Ports 
• Running a Simulation 
• Equivalent Circuit Extraction by Broadband SPICE 
• Broadband SPICE Model Validation 
• Transient Simulation by HSPICE 

4.1 Overview 
This section introduces PCB and overall modeling and simulation procedures. 
This section covers two topics:  
• PCB 
• Modeling and Simulation Procedure 

4.1.1 PCB 
The printed circuit board (PCB) sample has six metal layers, with traces, interconnections, a driver 
with power supply connections and a DC-voltage source. 
These components can be described as follows: 
• Six metal layers: A top signal layer, a bottom signal layer, a power plane and a ground plane, 

and two inner signal layers between the power and ground planes.  
• Traces: Routes on the top and bottom signal layers.  
• Interconnections: Between traces on different layers linked by vias.  
• Driver: Connected to the trace end on the left side of a board. The driver is described by a 

SPICE transistor level-3 model.  
• Driver power supply nodes: Connected to the power and ground planes.  
• DC-voltage source: Connected to the PCB at the edge. 
The following figure illustrates a cross-section of the structure:  
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4.1.2 Modeling and Simulation Procedure 
The general steps of modeling and simulation are as follows:  
1. Construct a package in PowerSI, or translate a board or package layout file into .spd 

format and load it into PowerSI.  
(See 3.2 Constructing a Package.) 

2. Define ports at locations where drivers, terminations, and DC sources are connected.  
(See 3.3 Specifying Ports.)  

3. Run simulation and obtain multiple-port S-parameter in Touchstone data format.  
(See 3.4 Running a Simulation.) 

4. Load a network parameter file into Broadband SPICE, and generate an HSPICE 
compatible equivalent circuit.  
(See 3.5 Equivalent Circuit Extraction by Broadband SPICE.) 

5. Generate an HSPICE netlist for an AC analysis to check the frequency response of the 
model.  
(See 3.6 Broadband SPICE Model Validation.) 

6. Generate an HSPICE netlist for the transient simulation.  
a. Connect a driver model, DC source, and termination to a multi-terminal equivalent circuit 

for the package obtained from Broadband SPICE.  
b. Run an HSPICE simulation for the netlist and observe power ground noise and 

waveforms at the driver and receiver (termination) ends.  
(See 3.7 Transient Simulation by HSPICE.) 

 

4.2 Constructing a Package  
This section describes how to construct, create, and add components into a package.  
This section covers the following topics:  
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• Construct a Package Model 
• Create Nets 
• Create a Stackup 
• Create Power Ground Shape and Setup Shape Properties 
• Add a Via 
• Add a Trace 
• Set up Trace Properties 
• Set up a Trace on Signal01 
• View Traces in 3D 

4.2.1 Construct a Package Model  
Follow these steps to construct a package model in PowerSI:  
1. Launch PowerSI. 
2. Select File > New.  

A default four-layer stackup opens. 

 

4.2.2 Create Nets 
1. Click the Net Manager tab to switch to Net Manager. 
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2. Right-click in the area and select New from the pop-up menu to create a new net. 

 
3. Repeat the above step to create one more new net. 

Two new nets are created. 
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4. Assign the two new nets with name GND and VCC. 

 
5. Define the colors for GND and VCC and select to enable both nets. 



PowerSI Tutorial 
 

January 2014                                                      26                                                  Product Version 16.6 

 
6. Move GND to GroundNets and VCC to PowerNets as the following figure shows. 

 

4.2.3 Create a Stackup  
Follow these steps to create a six-layer stackup:  
1. Select Edit > Stack Up.... 

 
The Stackup dialog box opens.  



PowerSI Tutorial 
 

January 2014                                                      27                                                  Product Version 16.6 

 
2. Add signal layers above and below the layer Medium02.  

a. Select the layer Medium02.  
b. Right-click Medium02 to open a pop-up menu.  
c. Select Insert Above > Signal Layer to add a new signal layer while a medium layer 

Medium04 is automatically added below Plane02.  

  
d. Repeat Step b and select Insert Under > Signal Layer to add a signal layer below 

Medium02 while a medium layer Medium05 is automatically added above Plane01.  

 
3. Change the Thickness unit to um from the Unit drop-down menu.  
4. Double-click the Thickness cells to change the values:  

• Click the Medium01 and Medium03 Thickness cells and input 200 um.  
• Click the Medium02, Medium04 and Medium05 Thickness cells and input 300 um.  
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Here, you can also set up Trapezoidal Trace Angle and Surface roughness for signal layers, 
or Permittivity and Loss Tangent for all layers. The default values are used for them in this 
example. 

 

TIP! 
Use the Ctrl or Shift key to select multiple rows in one column. When you 
select multiple rows in one column, a value box appears at the bottom of the 
Stackup dialog box, where you can change the value for the selected rows. 

5. Click the Pad Stack tab to switch to Pad Stack window.  

 
6. Click the New button to create a new padstack and assign it with the name padstack_r004.  
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7. Input 400 in the Outer Diameter field. 

 
8. Click OK to save your changes and exit the Layer Manager window.  

4.2.4 Create Power Ground Shape and Setup Shape Properties 
Follow these steps to create a power ground shape: 
1. Activate Plane02 in the Layer Selection window.  
2. Select View > Show > Show Shapes.  
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3. Choose the Select button  on the Select toolbar, and click any location on the shape to 
select the shape.  

4. Press the Delete key to delete the shape.  
5. Select View > Toolbars > Shape to bring up the Shape toolbar.  

 

6. Select the Box+ button  and draw a rectangle in the Layer View window. The screen 
automatically zooms into the new shape.  

 
7. Right-click the created shape to open a pop-up menu.  

 
8. Select Package1.Box01 to open the Box Properties dialog box. 

 
9. Set up the coordinates for Box01:  

• Unit: mm  
• Lower left corner coordinates: –1.00000e + 002 and –4.00000e + 001  
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• Width: 2.00000e + 002 
• Height: 8.00000e + 001  

10. Select VCC from the Net drop-down list and assign it to Box01. 

 
11. Click OK to save the changes.  
12. Activate Plane01 in the Layer Selection window. 

 
13. Repeat the above steps to delete the original shape in Plane01, and create a new shape 

(Box02). 
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14. Set up the coordinates for Box02. 
• Unit: mm  
• Lower left corner coordinates: –1.00000e + 002 and –4.00000e + 001  
• Width: 2.00000e + 002 
• Height: 8.00000e + 001  

15. Select GND from the Net drop-down list and assign it to Box02. 

 
16. Click OK to save the changes. 

4.2.5 Add a Via  
Follow these steps to add a via: 
1. Click anywhere in the Layer View window to make it active.  

2. Select the Add Via button  on the Object toolbar. 
3. Click a location (–25, 0) on the Layer View window.  

The cursor transforms into a + sign. The Via Editing dialog box opens.  
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TIP! 

The Status Bar shows the coordinates of the cursor timely. 
You can right-click to open a pop-up menu and select Type Coordinate… to 
open the Coordinate Input dialog box. You can input exact coordinates 
directly in the box. 

         

 
4. Select Signal02 and then Signal01 in the Via Editing dialog box.  

A via appears to connect the Signal02 and Signal01 layers. 
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5. Click OK.  

The added via is automatically named as Via01, which connects the traces routed on 
Signal01 and Signal02. 
 

NOTE! 
When adding vias, you may not get the exact coordinates as specified. Simply 
locate the coordinates as close as possible. The simulation result should not be 
highly affected by coordinates that are not exact. 

 

TIP! 

If you add a via at a wrong location, you can either:  
• Click the Select button  on the Select toolbar, drag to select the via, 

and then press the Delete key.  

• Use the Move button  on the Select toolbar to move the node to the 
right coordinates. 

For detailed information about the Select toolbar, see PowerSI User’s Guide. 

Repeat Step 2 to 6 to add the following vias. 

Via Coordinates Layers Descriptions 

Via02 25, 0 Signal02, Signal01 
Specify the traces routed on Signal01 and 
Signal02. 

Via03 –75, 1 Signal02, Plane02 
Specify the ports connecting the driver. 

Via04 –75, –1 Signal02, Plane01 

Via05 75, 1 Signal02, Plane02 
Specify the ports connecting the receiver.  

Via06 75, –1 Signal02, Plane01 

Via07 –0.5, –39 Signal02, Plane02 Specify the ports connecting the VRM module. 
Use the zoom button to pinpoint the 
coordinates. Via08 0.5, –39 Signal02, Plane01 
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TIP! 
Use Snap to Grid to set a 0.5 or –0.5 coordinates: Select Tools > Options > 
Edit Options… > Layout > Grid and Unit to check the Snap objects to grid 
option. 

4.2.6 Add a Trace 
Follow these steps to add a trace:   
1. Click Signal02 in the Layer Selection dialog box.  

The Signal02 icon becomes red. 

 
2. Click the Add Trace button  on the Object toolbar.  

The cursor becomes a + sign. 
3. To add a trace:  

a Find the coordinates (–74, 0) and click.  
b Find Via01 (–25, 0) and click.  
c Double-click to end this operation. Trace01 is added. 
Repeat Step 3 to add Trace02 from (74, 0) to (25, 0) at the via node.  

 

4.2.7 Set up Trace Properties 
Follow these steps to change a trace’s properties: 
1. Right-click Trace02 and select the trace name in the pop-up menu.  

The Trace Properties dialog box opens. 
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2. Change the trace width to 0.2 mm.  
Repeat Step 1 and 2 to change the Trace01 width to 0.2 mm.  

4.2.8 Set up a Trace on Signal01 
Follow these steps to change a trace on Signal01: 
1. Click Signal01 in the Layer Selection dialog box.  

The Signal01 icon becomes red.  
2. Add Trace03 from (–25, 0) to (25, 0) on the Signal01 layer.  

Via01 and Via02 are now connected by Trace03.  
3. Change the Trace03 width to 0.2 mm.  

4.2.9 View Traces in 3D 
Follow these steps to view traces in 3D:  
1. Select View > 3D View > Full 3D View.  

The 3D View window opens as follows: 
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2. Select View > Layer View to switch back to the Layer View window. 

4.3 Specifying Ports 
This section describes how to build a multiple terminal package model.  
This section has the following two topics:  
• Add Ports 
• Set up a Port 
The figure below shows a multiple terminal package model: 

 
Three devices/components will be connected to the package. Ports are specified in the package 
structure where the connection to external circuit components is made in HSPICE simulation.  
Follow these rules to specify PowerSI ports for connection with external circuit components in a 
SPICE-compatible circuit simulator:   
• Specify N ports for connecting the package to an N+1 terminal device.  
• Ensure that the specified N-port on the N+1 terminal device share the common reference (the 

negative “–” terminal of the port).  
• Ensure that all N ports specified for connection to one device are physically local because the 

device is considered to be a lumped circuit component.  
• Driver: A three-terminal device. Define two ports for it:  

Port1: (+)Out (Ref)Vgnd Port3: (+)Vcc (Ref)Vgnd  

• Termination: A two-terminal device. Define one port for it:  

Port2: (+)Termination + (Ref)Termination-  

• DC Source: A two-terminal device. Define one port for it:  

Port4: (+)VRM+ (Ref)VRM- 

4.3.1 Add Ports 
Add ports for connection to external components.  
Follow these steps to add ports: 
1. Select Signal02 in the Layer Selection dialog box.  

2. Click the New Port button  on the Port toolbar.  
The New Ports dialog box opens.  
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3. Set Start number to 1 and End number to 4 to add four ports.  
4. Click OK to save and exit.  

4.3.2 Set up a Port 
Follow these steps to set a port:  
1. Select Setup > Port….  

The Port dialog box opens.  

 
2. Select Port1.  
3. Find and right-click the left end of Trace01 (–74, 0).  

A pop-up menu appears. 

 
4. Select +Hook to assign the left node of Trace01 to the positive terminal of Port1.  
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5. Select the nearby Via04 located at (–75, –1), a ground via and connected to Plane01, and 
right-click to show a pop-up menu.  

6. Select –Hook to assign the upper node of Via04 to the negative (reference) terminal of Port1.  
7. Close the Port dialog box.  
8. Select File > Save to save the structure in the file psi_IO_modeling.spd. 
Repeat Step 2 to 6 to set up Port2 to Port4.   

Port2 
• Positive Terminal: The right end of Trace02 (74, 0).  
• Negative Terminal: The node of the ground via Via06 located at (75, –1).  

Port3  
• Positive Terminal: The upper node of Via03 located at (–75, 1).  
• Negative Terminal: The lower node of Via04 located at (–75, –1)  

Port4  
Use the zoom button to enlarge the area so that you can select the correct node.  
• Positive Terminal: The node of the power via Via07 located at (–0.5, –39).  
• Negative Terminal: The node of the ground via Via08 located at (0.5, –39). 
The Port dialog box looks like the following figure after four ports are defined.  
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4.3.3 Set Reference Impedance for the Port 
To set reference impedance for the port, select 
Tools > Options > Edit Options… > Simulation(basic) > Network Parameters  

 
By default, Power Nets is set to 1Ohm and Signal Nets is set to 50Ohm. 

4.4 Running a Simulation 
This section describes how to simulate the package with ports defined in the file 
psi_IO_modeling.spd generated in Section 4.3 Specifying Ports.  
This section has the following topics:  
• Set up Simulation Frequencies 
• Run a Simulation 
• Export Results 

4.4.1 Set up Simulation Frequencies  
Follow these steps to set up simulation frequencies:  
1. Select Setup > Simulating Frequencies….  

The Frequency Ranges dialog box opens.  

 
2. Change the following parameters:  

• Starting Freq. to 1 MHz 
• Ending Freq. to 5.0 GHz 
• Sweeping Mode to Linear 
Freq. Increment becomes 10 MHz automatically. 
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3. Click OK to save and exit.  

4.4.2 Run a Simulation  
1. Press the Start Simulation button  on the Simulating toolbar.  

The Port Curves window appears.  

 
The curve window automatically displays the S-parameter curves for four ports. 

4.4.3 Export Results  
Follow these steps to export the simulation results in different formats:  
1. Select File > Save Simulation Result.  

The Save Curves dialog box opens.  
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2. Select Touchstone format as the file format.  
3. Select RI as the data type.  
4. Select S under Save the following network parameter(s).  
5. Rename the file to model_IO.s4p.  

 
6. Click OK to save the file and exit the Save Curves dialog box.  

The following header format for S parameter is supported in touchstone file: 
! GNDNET NET014 
! NETSLIST NET029, NET019 
! Port 1 = U3_1 NET029 
! Port 2 = U1_2 NET019 
! Port 3 = U4_1 NET019 
! Port 4 = U6_2 NET029 

The nets and ports are specifically bound to each other. No implicit assumptions are made in 
this case and only the explicit binding specified in the header is honored. 
GNDNET and NETSLIST are solver specific optional parameters: 
• GNDNET specifies the net to which all the ground pins in the model should be connected 
• NETSLIST is a comma separated list of nets which should be deleted from the schematic 

when the model gets assigned 
7. Select File > Exit to close the project. 

4.5 Equivalent Circuit Extraction by Broadband SPICE 
This section uses the network parameter file model_IO.s4p to extract equivalent circuits in 
Broadband SPICE. 
Follow these steps to extract equivalent circuits:   
1. Launch Broadband SPICE.  
2. Select File > Open… to open the file model_IO.s4p.  

3. Choose the Extract button  on the Action toolbar to start an extraction. 
The following window shows the extraction result:  
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4.6 Broadband SPICE Model Validation 
This section describes how to use HSPICE AC Analysis to check the frequency response of the 
model before proceeding with the transient simulation of the package models with the driver, DC 
source, and terminations. HSPICE AC Analysis should match the PowerSI simulation results.  
The .net function is used in HSPICE. Because the .net function can only simultaneously obtain 
two port parameters, you need to compute the partial entries of the port S-parameters of an N-port, 
by connecting the reference impedance (50 ohms) to the rest of the ports.  
The following HSPICE netlist (Validate_Model_IO.sp) exemplifies the computation of S11, 
S12, S21, and S22 of the four-port. The following AvanWave screen capture shows the results of 
an S11 (magnitude) from the 1 MHz to 5 GHz, which matches the PowerSI simulation.  
The Validate_Model_IO.sp file includes a file Model_IO.txt. This file is a Broadband 
SPICE-extracted equivalent circuit file. Both files should be within the same directory.  
* Using .net statement to find S parameter of a 4-port network  

.include 'Model_IO.txt'  

.AC lin 1Meg 20Meg 5000Meg. 

.net v(p2) vin rout = 50 rin = 50  

vin p1 0 AC 1  

X1 p1 p2 p3 p4 0 Model_IO  

R3 p3 0 50  

R4 p4 0 50  

.probe AC S11(m)  

.probe AC S12(m)  

.probe AC S21(m)  

.probe AC S22(m)  

.end 
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See your HSPICE application user guide for information on how to check the frequency response.  
 

NOTE! 

• The equivalent circuit model (in terms of SPICE sub-circuit) for an N-port 
S-parameter includes N+1 nodes, where the first N nodes corresponds to 
the N-port terminals. The last node corresponds to the reference of all the 
N-ports. 

• In a SPICE simulation, the N-terminal nodes of the sub-circuit should be 
connected to the device terminals for which the positive terminals of the 
ports are specified in PowerSI.  

 

4.7 Transient Simulation by HSPICE 
This section describes how to perform a transient simulation for IO analysis and to observe the 
power supply noise at the driver’s power ground pins.  
This section has the following topics:  
• Prepare an HSPICE Netlist 
• View HSPICE Simulation Results 

4.7.1 Prepare an HSPICE Netlist  
You can find the file Driver_Package.sp and MC74LCX16244.txt under the Broadband 
SPICE > Samples directory.  
 The file MC74LCX16244.txt contains a transistor-level model for a particular driver.  
 The file Driver_Package.sp contains the following information:  

* Ground bounce simulation using transistor level model 

* Last Updated: May 23, 2002 

* File name: Driver_Package.sp  

 

.option probe post=2 ingold = 2 numdgt = 10 

.param Z0 = 50 

 

* Include the HSPICE level-3 model for the driver 
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.include 'MC74LCX16244.txt' 

 

* Include the equivalent circuit model for the package 

.include 'app1_drv.txt' 

 

* The termination 

 

R2 2 0 10meg 

 

* The DC supply model  

 

Vdc_supply 4 t4 DC 3  

Rdc_supply t4 0 1e-5 

 

* Connect the equivalent circuit to the driver model etc.  

* 1: Driver output node       2: Termination+ node 

* 511: Vcc node of the driver 4: DC source positive node 

 

X1 1 2 511 4 0 app1_drv 

 

.tran  0.005ns 15ns 

 

.probe tran v(512) V(510) GroundBounce = par('V(518)-V(522)') 
v(518) v(522) v(1) v(2) v(4) v(511) v(510) 

.print tran v(512) 

.print tran GroundBounce = par('V(518)-V(522)') 

.print tran v(2) 

 

.end  

4.7.2 View HSPICE Simulation Results  
After the HSPICE simulation is completed, you should get a view as follows:  
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 The upper half shows the waveform at the driver-end (in blue) and the waveform at the 

termination end (in red).  
The input signal to the driver is a pulse with 1 ns rise-time specified in the netlist.  

 The lower half shows the voltage between the VCC node and the Vgnd node of the driver.  
The figure shows that the actual supply at the driver fluctuates around three volts due to the 
driver’s switching activity. 
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5 Project 3 Decoupling Capacitors 
Placement 

This chapter describes how to select and place decoupling capacitors to minimize the power 
delivery system noise. This chapter takes the following files as examples:  
• psi_brd_PDSdesign_NoDecp.spd 
• psi_brd_PDSdesign_Decap_stage1.spd 
• psi_brd_PDSdesign_Decap_stage2.spd 
These files have been installed when you install PowerSI on your computer. 
This chapter has the following sections: 
• Power Ground Noise Without Decoupling Capacitors 
• Decoupling Capacitor Placement (First Round) 
• Decoupling Capacitor Placement (Second Round) 
• Self and Transfer Impedance of the Power Delivery System 
Project Specifications:  
• The PCB size is 12” x 8” and has a Signal-Power-Ground-Signal stackup. 
• The power and ground metal layers are copper and 1.4 mils thick. 
• The dielectric layers are FR4 material (dielectric constant = 4.0, lossless). 
• The dielectric layer thickness between power and ground planes is 5 mils. 

5.1 Power Ground Noise Without Decoupling Capacitors 
This section has the following topics:  
• Start PowerSI and Load a File 
• View Circuits 
• View Circuit Voltages 
• View Voltage Distributions 
• Set up Simulation Frequencies 
• Run a Spatial Mode Simulation 

5.1.1 Start PowerSI and Load a File 
Follow these steps to start PowerSI and load a file:  
1. Launch PowerSI.  
2. Select Mode > Spatial Mode to set the Spatial Solution mode for this simulation.  
3. Select File > Open… and choose psi_brd_PDSdesign_NoDecap.spd. 
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In this example, three current sources around the center of the board represent the current sink at 
these locations. The center current source is 150 mA and the other two are 75 mA. A resistor at the 
lower left of the board represents the Voltage Regulator Module and its value is 0.01 ohm. 

5.1.2 View Circuits 
Follow these steps to view connected circuits in details.  
1. Select Setup > Circuit/Linkage Manager. 

 
Spatial Mode requires at least one active circuit to act as the stimulus for the simulation.  AC 
current sources are typically used and can be automatically created under the Noise 
Coupling Analysis Workflow > Setup Excitation. 
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2. Close the Circuit/Linkage Manager window without any changes. 
 

NOTE! 
This sample contains one VRM and three Sinks. For more information about 
how to set up VRM and Sink, please refer to Working with Circuits in the 
document SPD_Layout_UG. 

5.1.3 View Circuit Voltages  
Follow these steps to view the circuit voltage variables:  
1. Select Setup > Simulation View > Ckt Voltage… to open the following window. 

 
Three minimized Sink voltages are selected.  

2. Click OK.  
In this example, the voltages of all three sink current locations have been defined. These 
voltages are the ones being minimized in this tutorial. 

For more information about how to set circuit voltages, see Preparing for the Simulation > Setup 
the Sources and Observations in Spatial Mode > Specify Circuit Voltage in the document 
PowerSI_UG.  

5.1.4 View Voltage Distributions  
Follow these steps to view voltage distributions:  
1. Select Setup > Simulation View > 3D Spatial… to review the voltage distribution. The 

Voltage Distribution dialog box appears. 
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In this example, a plane pair PlaneVDD ~ PlaneGND is selected as shown in the 
Distribution text box.  

2. Click OK.  

5.1.5 Set up Simulation Frequencies 
Follow these steps to set up simulation frequencies:   
1. Select Setup > Simulating Frequencies….  

The Frequency Ranges window opens. 

 
2. Change the following parameters:  

• Starting Freq. to 1 MHz 
• Ending Freq. to 600 MHz 
• Sweeping Mode to Linear 
• Freq. Increment to 10 MHz   

3. Click OK.  

5.1.6 Run a Spatial Mode Simulation  
Follow these steps to perform a simulation and view the curves:   
1. Click the Start Simulation button  to start the simulation.  

The 3D View window opens.  
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The window contains 3D plots for the voltages between the selected plane pairs. 
The 3D Result Display Control dialog box opens at the same time.  

 
2. Select Window > Spatial Curves to view the Spatial Curves window. 
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This window contains 2D frequency responses of the selected voltage or current variables. 
The red, blue, and green curves are the noise voltages at the three specified sink locations. 
Parallel resonance peaks appear in all three voltage locations.  

3. Right-click the plot to show a pop-up menu.  

 
4. Select Save to store the voltage curves as NoDecap.cur for later comparisons. 

5.2 Decoupling Capacitor Placement (First Round) 
This section describes how to reduce the noise voltages to below 100 mV up to 500 MHz.  
This section has the following topics:  
• Review Spatial Voltage Distributions 
• Determine Decoupling Capacitor Locations 
• Determine Decoupling Capacitor Types and Values 

5.2.1 Review Spatial Voltage Distributions 
Follow these steps to review the spatial voltage distributions:   
1. Select Window > 3D View and select the 3D Result Display Control tab. 
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2. Input values in Start Freq. and End Freq., or scroll the slide bars to adjust the values.  

3. Click  to run.   

4. Click  to display the maximum (peak) voltage distribution in the window. The 
maximum voltage within the frequency range appears for each mesh node.  

 
The above figure shows three hot-spot locations where the color becomes orange to red. The 
peak noise voltages exceed 350 mV at these locations.  

5.2.2 Determine Decoupling Capacitor Locations  
Follow these steps to determine decoupling capacitor locations:  

Add a Voltage versus Frequency curve at the hot-spot locations  
1. Double-click a hot-spot location.  
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The Add Curve window opens.  

 

2. Click  to add a voltage response at this location to the Spatial Curves window. 
Repeat Step 1 and 2 to add other hot-spot voltage responses to the Spatial Curves window.  

View the Voltage versus Frequency curve at the hot-spot locations  
1. Select Window > Spatial Curves to display the Spatial Curves window.  

 
Three voltage curves have parallel resonances at 61, 371, 461 and 501 MHz. 

2. Close the current project without saving. 

5.2.3 Determine Decoupling Capacitor Types and Values  
This section describes how to determine decoupling capacitors and their values. The purpose of 
the determination is to remove the resonance peaks at the listed frequencies.  
Use the capacitors with corresponding resonance frequencies below:  

Capacitor 
Type 

Resonance frequency 
(MHz) 

Capacitor 
(F) 

Inductance 
(H) 

Resistance 
(ohm) 

IDC0508 64.14 56 n 0.1 n 0.12 
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0508 357.75 330 p 0.6 n 1.39 

0508 438.15 220 p 0.6 n 1.58 

0508 484.39 180 p 0.6 n 1.65 

The decoupling capacitors are located at where the 2D voltage curves are generated.  
The pre-built file psi_brd_PDSdesign_Decap_stage1.spd contains three sets of decoupling 
capacitors as mentioned above. These capacitors are placed at the three hot-spot locations.  
Follow these steps to run a simulation:  
1. Select File > Open…, and open psi_brd_PDSdesign_Decap_stage1.spd from the 

<INSTALL_DIR>\SpeedXP\Samples\PowerSI\Hybrid\ directory.  

 
This example has 12 decoupling capacitors placed at the desired locations.  

2. Select Setup > Circuit/Linkage Manager to verify that the decoupling capacitors have been 
added.  
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3. Click the Start Simulation button  to start the simulation.  
4. Select Window > Spatial Curves to switch to the Spatial Curves window. 

 
The red, blue, and green curves are the noise voltages at the three specified sink locations 
with slightly reduced magnitude. In this example, the noise voltages still exceed the expected 
100 mV in the frequency range between 400 to 500 MHz.  

5. Right-click the plot to display a pop-up menu.  
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6. Select Save to save the voltage curves as Decap1.cur for later comparisons. 

5.3 Decoupling Capacitor Placement (Second Round) 
In the previous exercise, the noise voltages are lowered, but still violate specification in the 
frequency range between 400 to 500 MHz. In this section, the noise voltages between 400 to 500 
MHz will be lowered to the expected 100 mV.  
This section has the following topics:  
• Review Spatial Voltage Distributions 
• Determine Decoupling Capacitor Locations 
• Determine Decoupling Capacitor Types and Values 

5.3.1 Review Spatial Voltage Distributions  
Follow these steps to review the spatial voltage distributions:  
1. Select Window > 3D View.  

2. Select the 3D Result Display Control dialog box and click the Show Peak button  
to display the maximum (peak) voltage distribution in the 3D View window. 
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Two hot-spots are at the lower right and upper-left corner. The peak noise voltages exceed 200 
mV at both locations.  

5.3.2 Determine Decoupling Capacitor Locations  
Follow these steps to determine decoupling capacitor locations:  

Add a Voltage versus Frequency curve at hot-spot locations  
1. Double-click a hot-spot location.  

The Add Curve dialog box opens.  

 

2. Click  to add the voltage response at this location to the Spatial Curves window. 
Repeat Step 1 and 2 to add other hot-spot voltage responses to the Spatial Curves window.  

View the Voltage versus Frequency curve at hot-spot locations  
1. Select Window > Spatial Curves to display the Spatial Curves window.  

Two new voltage response curves are shown in the panel: VDD_GND_–0.149423_0.088384 
and VDD_GND_0.144913_–0.090919. 
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Both of voltage curves have parallel resonances at 131 and 471 MHz.  

2. Close the current project without saving. 

5.3.3 Determine Decoupling Capacitor Types and Values   
This section describes how to determine decoupling capacitors and their values. The purpose of 
the determination is to remove the parallel resonance peaks at the frequencies listed.  
Use the capacitors with corresponding series resonance frequencies below:  

Capacitor 
Type 

Resonance frequency  

(MHz) 
Capacitor 

(F) 
Inductance 

(H) 
Resistance 

(ohm) 

IDC0508 138.56 12 n 0.1 n 0.23 

0508 438.15 12 p 0.6 n 1.58 

The decoupling capacitors are located at the hot-spots where the 2D voltage curves are generated.  
The prebuilt file psi_brd_PDSdesign_Decap_stage2.spd contains two IDC0508 capacitors 
and two 0508 capacitors placed at each of the two hot-spot locations. 
1. Select File > Open…, and open psi_brd_PDSdesign_Decap_stage2.spd from the 

<INSTALL_DIR>\SpeedXP\Samples\PowerSI\Hybrid\ directory.  
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Eight additional decoupling capacitors have been added.  

2. Select Setup > Circuit/Linkage Manager to display the Circuit/Linkage Manager dialog 
box to verify that the decoupling capacitors have been added.  

 
3. Click the Start Simulation button  to start the simulation.  

The Spatial Curves window opens like the following figure. 
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The red, blue, and green curves are the noise voltages at the three specified sink locations 
with slightly reduced magnitude. In this example, the noise voltages have been lowered up to 
500 MHz. The noise voltages up to 400 MHz are lower than 60 mV.  

4. Right-click the plot to display the pop-up menu.  

 
5. Select Load to load the stored voltage curves in NoDecap.cur.  

The Load Curve dialog box opens.  

 



PowerSI Tutorial 
 

January 2014                                                      62                                                  Product Version 16.6 

6. Click  to load all the curves and click . 

 
There has been significant noise voltage reduction at the various sink locations.  

7. Close the current project without saving. 

5.4 Self and Transfer Impedance of the Power Delivery System 
This section describes how to view the self and transfer impedance (impedance parameter matrix) 
with and without decoupling capacitors, and further demonstrate the improvements on the 
performance of the power delivery system.  
This section has the following topics:  
• Simulate Self and Transfer Impedance Curves 
• Run Simulation with Decoupling Capacitors 

5.4.1 Simulate Self and Transfer Impedance Curves  
This section describes how to show hooked ports, run a simulation without decoupling capacitors, 
and view different ports after the simulation.  

Show hooked ports and run a simulation without decoupling capacitors 
1. Select Mode > Extraction Mode. 
2. Select File > Open…, and open the file psi_brd_PDSdesign_NoDecap.spd from the 

<INSTALL_DIR>\SpeedXP\Samples\PowerSI\Hybrid\ directory.  
 

NOTE! 

In some cases, you might see a warning regarding the circuit definitions of the 
source components. The Extraction Mode does not accept independent 
voltage or current sources that do not equal zero, and gives out a warning. In 
this example, the voltage source = 0. If you see this warning and wish to keep 

the circuit definitions of the source components, click . 
3. Select View > Show > Show Hooked Ports to enable hooked port view.  

Three pre-specified ports at the sink locations appear as in the following figure: 
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4. Click the Start Simulation button  to start the simulation without decoupling capacitors. 
All port curves appear on the plot.  

 
5. Choose the Z (impedance) parameter from the Curve Settings toolbar.  

 
The resulting curve presents a Z-parameter.  
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View all different ports 
By default the display shows the S-parameter matrix diagonal components or reflection. When 
you select Z from the Curve Settings toolbar, the self impedance at each port shows. To view 
transfer impedance, plot the transmission parameters. 

1. Click the Channel Filter button  on the Curve Operations toolbar to open the Channel 
Filter dialog box. 

 
2. Check Insertion Loss.  
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3. Click  to show impedance parameters.  

 
This window shows all of the impedance parameters, both self and transfer impedance for the 
top half matrix. 

4. Right-click the display to open a pop-up menu.  

 
5. Select Save Simulation Result to save the S-parameters and impedance matrix in the 

psi_brd_PDSdesign_NoDecap.S3P for later comparison.  
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6. Select Window > Layer View to switch to the Layer View window.  
7. Select File > Close to close the current project.  

5.4.2 Run Simulation with Decoupling Capacitors 
1. Select File > Open… to open the file psi_brd_PDSdesign_Decap_stage2.spd from the 

PowerSI Samples directory.  
 

NOTE! 

In some cases, you might see a warning regarding the circuit definitions of the 
source components. The Extraction Mode does not accept independent voltage 
or current sources that do not equal zero, and gives out a warning. In this 
example, the voltage source = 0. If you see this warning and wish to keep the 
circuit definitions of the source components, click Yes. 

 
2. Press the Start Simulation button  to start the simulation.  

All port curves appear on the plot.  
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3. Choose the Z (impedance) parameter from the Curve Settings toolbar.  

 
The resulting curve presents a Z-parameter.  

 
View all different ports 
By default the display shows the S-parameter matrix diagonal components or reflection. When 
you select Z from the Curve Settings toolbar, the self impedance at each port shows. To view 
transfer impedance, plot the transmission parameters. 

1. Click the Channel Filter button  on the Curve Operations toolbar to open the Channel 
Filter dialog box. 
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2. Check Insertion Loss.  

 

3. Click  to show impedance parameters.  

 
This window shows all of the impedance parameters, both self and transfer impedance for the 
top half matrix. 

4. Right-click the Network Parameters to open a pop-up menu.  
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5. Select Load to load psi_brd_PDSdesign_NoDecap.S3P for comparison.  

The curves display like in the following figure. 

 

 
6. Select Window > Layer View to switch to the Layer View window.  
7. Select File > Close to close the current project.  
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5.5 Resonance Mode 
In PowerSI, the resonance mode solver computes and displays all the resonant modes between 
predefined frequency ranges. User can also specify the number of resonant modes directly. 
Follow these steps to start resonance mode analysis:  

5.5.1 Start PowerSI and Switch to the Resonance Mode  
1. Launch PowerSI.  
2. Select Mode > Resonance Mode to switch to Resonance Mode.  
3. Select File > Open… to open the file psi_brd_PDSdesign_Decap_stage2.spd from the 

<INSTALL_DIR>\SpeedXP\Samples\PowerSI\Hybrid\ directory.  

 

5.5.2 Set up Frequency Range  
1. Select Tools > Options > Edit Options… > Resonance > Setting to show the Frequency 

Ranges dialog box.  

 
2. To extract all the resonant modes between frequency ranges, specify Frequency Min and 

Frequency Max in the field next to them.  
or 
To extract total number of resonant modes, check Enable Total Mode and enter a number in 
the field of Total Frequency Number. 
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3. Click .  
4. (Optional) Select Setup > Simulation View > 3D Spatial… to set up the 3D spatial voltage 

display.  

 

5.5.3 Run a Simulation  
Click the Start Simulation button  to start a simulation.  
The 3D view looks as shown below.  

 
PowerSI outputs a table which lists complex resonant frequencies and Q factors in the 3D Result 
Display Control window as shown below: 
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If the 3D spatial is set up, PowerSI also shows the normalized voltage field distribution at 
corresponding resonant frequencies. 
You can click an Eigen entry to view the normalized voltage field distribution at each potential 
resonant frequency.  
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6 Project 4 IR Drop Analysis for Power 
Delivery Systems 

This chapter describes how to analyze the DC current drop (IR drop) for power delivery system. 
The IR drop refers to the off-set of the DC voltage supply due to the distributed resistance 
associated with the metals, such as shapes and traces, in the power delivery system.  
This chapter uses the following files as examples:  
• psi_DCR1_200x10mm_1plane.spd  
• psi_DCR2_100x1mm_1plane.spd   
• psi_DCR3_100x1mm_2planes.spd  
• psi_brd_IR_drop_SM.spd  
These examples give detailed steps of how to perform DC analysis for most situations and 
analysis. The first two examples in this chapter show the computation of resistance associated with 
power/ground nets. The last example explains how to determine the voltage drop in the spatial 
mode.  
This chapter has the following sections:  
• Power Delivery System Resistance (I) 
• Power Delivery System Resistance (II) 
• Power Delivery System Resistance (III) 
• Simulating IR Drop in the Spatial Mode 

6.1 Power Delivery System Resistance (I) 
In this example, you compute the resistance associated with the VCC net as shown below:  

 
The Vcc plane has the following specifications:  
• 200 mm long (L)  
• 10 mm wide (W)  
• 5 um thick (T)  
• Conductivity 5.8e7 S/m (σ)  
• Two rows of vias, acting as testing points, are 0.5 mm away from the plane edge.  
Consequently, the actual DC path for the plane is 199 mm (L). The vias are 1 um long and have 
negligible DC resistance. Because the plane is a thin rectangular strip, the DC resistance of the 
Vcc plane can be found analytically using the following formula:  

 
The PowerSI simulation results should closely match the formula results.  
This section has the following sections:  
• Open a Project 
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• Set up Simulation Frequencies 
• Turn on Inter-plane Coupling 
• Run a Simulation 

6.1.1 Open a Project 
This section describes how to open a project and show hooked ports in the Extraction Mode.  
1. Launch PowerSI.  
2. Select File > Open… and choose the file psi_DCR1_200x10mm_1plane.spd from the 

<INSTALL_DIR>\SpeedXP\Samples\PowerSI\Hybrid\ directory.  
3. Select View > Show > Show Hooked Ports to make sure that the Show Hooked Ports 

option is enabled.  

 
In this example, a port has been specified at where the positive terminal connects to multiple 
points at the left end of the VCC plane, and the negative terminal connects to multiple points at 
the right end of the VCC plane.  

6.1.2 Set up Simulation Frequencies  
Follow these steps to set up simulation frequencies:   
1. Select Setup > Simulating Frequencies….  

 
2. Change the following parameters:  

• Starting Freq.  to 100 Hz  
• Ending Freq. to 200 Hz  
• Sweeping Mode to Linear  
• Freq. Increment to 100 Hz  

3. Click OK.  
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TIP! 
Set the simulation frequencies as these values when you use PowerSI to 
analyze DC. 

6.1.3 Turn on Inter-plane Coupling  
Follow these steps to turn on the inter-plane coupling:  
1. Select Tools > Options > Edit Options… > Simulation (Advanced) > Field Domain.  
2. Select Basic mode under Inter-plane coupling (IPC).  

 

3. Click .  
 

TIP! 
Always enable Inter-plane coupling to ensure accuracy during the DC 
analysis. 

6.1.4 Run a Simulation  
Follow these steps to run a simulation:  
1. Press the Start Simulation button  to start the simulation.  
2. Choose the Z parameter and Real from the drop-down menus on the Curve Settings toolbar.  

           
The curve looks as shown below: 
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The resistance result is around 0.068500 ohms which is consistent with the analytical result. 

6.2 Power Delivery System Resistance (II)  
In this example, you compute the resistance associated with the Vcc net as shown below.  

 

Both the Vcc and Vss planes have the same specifications:  
• 100 mm long (L)  
• 1 mm wide (W)  
• 5 um thick (T)  
• Conductivity is 5.8e7 S/m (σ).  
Because the plane is a thin rectangular strip, the DC resistance of either plane can be found 
analytically using the following formula:  

 
The PowerSI simulation results should closely match the formula results. 

6.2.1 Compute Resistance  
Follow these steps to compute resistance:  
1. Open a Project and load the file psi_DCR2_100x1mm_1plane.spd.  

See 5.1.1 Open a Project.  
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In this example, the positive terminal is connected to the Vcc plane on the left through a 
through-hole via, and a negative terminal connected to the Vss and Vcc planes on the right.  

2. Select Setup > Simulating Frequencies…. See 5.1.2 Set up Simulation Frequencies. 

 
3. Change the following parameters:  

• Starting Freq. to 100 Hz  
• Ending Freq. to 200 Hz  
• Sweeping Mode to Linear 
• Freq. Increment to 100 Hz  

4. Click .  

5. Press the Start Simulation button  to start the simulation.  
See 5.1.4 Run a Simulation. 
The Z-real parameter curve appears as shown below.  
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The resistance result is 0.3430 ohms closely matching the analytical results. 

6.3 Power Delivery System Resistance (III) 
In this example, the structure is similar to the previous one. However, the via on the left end also 
stops at the Vss plane, making contact with the Vss plane. Because the Vss plane is identical to the 
Vcc plane, the resistance seen from the port is half that of the previously computed Vcc net in the 
previous example.  
The result can be analytically computed by the following equation:  

 

6.3.1 Compute Resistance 
Follow the steps in 5.1 Power Delivery System Resistance (I), but use this file 
psi_DCR3_100x1mm_2planes.spd.  
The following figure shows the results and is consistent with the analytical solution: ~0.172 ohms. 
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6.4 Simulating IR Drop in the Spatial Mode  
This section describes how to use PowerSI to simulate IR drop in the spatial mode and DC 
voltage distribution across power ground planes.  
In this example, a 3.3 V voltage source (DC) is connected to the power ground planes at the lower 
right corner of the board. Three pre-specified sink locations are modeled using current sources.  
The spatial mode simulation easily identifies the locations where the voltage reduction exceeds a 
defined threshold.  
This section has the following topics:  
• Start PowerSI and Load a File 
• View Circuits 
• Set up Voltages 
• Set up Spatial Voltage Distributions 
• Set up Simulation Frequencies 
• Turn on Inter-plane Coupling 
• Run a Simulation 

6.4.1 Start PowerSI and Load a File 
Follow these steps to start PowerSI and load a file:  
1. Launch PowerSI..  
2. Select Mode > Spatial Mode.  
3. Select File > Open… and choose psi_brd_IR_drop_SM.spd.  
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The figure shows three sink locations and one voltage source connected.  

6.4.2 View Circuits 
Follow these steps to view the information for each of these locations:  
1. Select Setup > Circuit/Linkage Manager.  

 
2. Close the Circuit/Linkage Manager window without any changes. 

6.4.3 Set up Voltages 
Follow these steps to set up the circuit voltage:  
1. Select Setup > Simulation View > Ckt Voltage… to specify the voltages of the sink 

locations.  
For this example, the sink locations have already been selected for viewing voltage. 
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2. Click  or  to exit.  

6.4.4 Set up Spatial Voltage Distributions 
Follow these steps to set up or view voltage distributions:  
1. Select Setup > Simulation View > 3D Spatial to review the voltage distribution.  

The Voltage Distribution dialog box opens. 

 
For this example, the spatial voltage distributions have already been specified.  

2. Click  or  to exit.  

6.4.5 Set up Simulation Frequencies 
Follow these steps to set up simulation frequencies:   
1. Select Setup > Simulating Frequencies….  
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The Frequency Ranges dialog box opens. 

 
2. Change the following parameters:  

• Starting Freq. to 100 MHz 
• Ending Freq. to 200 MHz 
• Sweeping Mode to Linear 
• Freq. Increment to 100 MHz  

 

NOTE! The Adaptive sweeping is not available in the Spatial Mode. 

3. Click .  

6.4.6 Turn on Inter-plane Coupling  
Follow these steps to turn on the inter-plane coupling:  
1. Select Tools > Options > Edit Options… > Simulation (Advanced) > Field Domain.  
2. Select Basic mode under Inter-plane coupling (IPC).  



PowerSI Tutorial 
 

January 2014                                                      84                                                  Product Version 16.6 

 

3. Click .  

6.4.7 Run a Simulation 
Follow these steps to perform a simulation and view the curves:   
1. Click the Start Simulation button  to start the simulation.  

The 3D View window opens.  

 
2. Select Windows > Spatial Curves to see the spatial curves.  
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The spatial curve window displays the actual voltages across the sink locations.  

3. Select Tools > Options > 3D View Settings… to set up Display and Quality.  
Set up display options in the following window.  

 
4. Set up parameters for the 3D view in the 3D Result Display Control dialog box.  
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