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1. 库编辑器                                 (40 minutes) 

创建库器件部分介绍了各种库类型和在 Altium Designer 中创建和管理库文件的方式。  

本部分将详细描述原理图和 PCB 库编辑器的使用方法，另配有操作练习，学习如何在原理

图库中创建单部件和多部件封装、创建 PCB 封装、安装模型和使用不同库文件。 我们还将介

绍集成库 ― 一种安全、轻便、经过汇编的库文件。  

本部分还将讨论如何添加器件参数，并配有从供应商管脚列表中导入管脚信息的操作练

习。 

图 1  在 Altium Designer 中创建器件库的操作流程图 

 
图 1  Altium Designer 器件创建流程. 
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1.1 原理图库编辑器及创建元件符号 

本部分讲述如何使用原理图库编辑器和如何创建新器件。 原理图库编辑器用于： 

 创建和修改原理图器件符号 

 在模型中安装器件 

 添加参数到器件 

 管理器件库 

原理图器件库编辑器的操作方式和原理图编辑器类似，并共享相同的图对象类型（但不共

享电气对象）。 此外，原理图器件库编辑器另有对象 ― 管脚，它用在电线和器件的连接处。 

 

图 2  原理图库编辑器工作区 

执行 File » Open 菜单命令可打开 Schematic Libraries (*.SchLib) 进行编辑。 导航到所需

器件库所在文件夹并找到该库，如：C:\Program Files\Altium Designer 

6\Examples\Training\Temperature Sensor\Libraries\Temperature Sensor.SchLib，然后单击 Open。  

　集成器件库（*.IntLib）属于编译二进制文件，不能编辑。如果试图打开一个集成库，该

库将进行反编译操作，也就是说，所有源库都会解压缩，并创建新的库包。软件提供的所有器

件库都是集成库。 

   Schematic Libraries (*.SchLib)  执行 File » Open 菜单命令可打开 Schematic 

Libraries (*.SchLib) 进行编辑。 导航到所需器件库所在文件夹并找到该库，如：C:\Program 
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Files\Altium Designer 6\Examples\Training\Temperature Sensor\Libraries\Temperature 

Sensor.SchLib，然后单击 Open。  

原理图器件库编辑器有右键菜单、Utilities 工具栏和 Mode 工具栏（如图 3 所示） Utilities 

工具栏包括一系列标准绘图工具和全套 IEEE 符号。 

 

图 3  库编辑工具栏和右键命令选项 

1.1.1 原理图库编辑器术语 

 对象 ― 能放置在原理图器件库编辑器工作区内的任何单独项目，例如管脚、直

线、弧线、多边形和 IEEE 符号等。 

注： 符号的 IEEE 范围在放置过程中都可以调整大小。 在放置符号时，按住 + 和 – 键可扩

大和缩小它们。 

 部件 ― 图表对象的集合，用来表示多部件器件中的一个部件（如 7404 里的反相

器），或是通用或独立封装器件中的一个封装器件（如电阻器或 80486 微处理

机）。 

 Zero 部件 ― 这是多部件器件中才有的专用不可视部件。 在将器件放置到原理图上

时，添加到 Part Zero 中的管脚会自动添加到器件的每个部件上。 要将管脚添加到 

Part Zero，请将其放置在任何部件上，对它进行编辑，并将 Pin Properties 对话框中

的 Part Number 属性设为 Zero。 

 器件 ― 可以是单个部件（如电阻器），也可以是封装在一起的部件集合（如 

74HCT32）。 

 别名 ― 指当库器件有多个名称共享相同器件描述和图形图像时的命名方法。 例

如，74LS04 和 74ACT04 可以是 7404 的别名。共享图形信息可以使库变得更为紧

凑。 

 隐藏管脚 ― 指器件上存在但不需要显示的管脚。 这种情况通常适用于电源管脚。

执行此操作后，电源管脚可自动连接到 Pin Properties 对话框中指定的网络。 该网

络不需要出在在原理图上；网络创建后，它将名称为 Connect To net 的所有隐藏管

脚都连接起来。 在原理图图纸上可见（也就是不隐藏）的管脚不会自动与其连接。 
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图 4  原理图库面板 

在 Component Properties 对话框中选择 Show All Pins 选项，可以将隐藏管脚显示在

原理图图纸上。 

 方式 ― 一个器件可以有高达 255 种不同的显示方式。 它适用于 IEEE 器件表示和

运算放大器的备用管脚排列等。 使用 Tools » Mode 子菜单或 Mode 工具栏中的选

项可为器件添加新的显示方式。 器件的显示方式可在原理图图纸中改换。 

1.1.1.1   原理图器件库编辑器面板 

原理图器件库编辑器（Schematic Library 

Editor）面板提供了大量的原理图器件处理功

能。 具体功能如下。 面板每个区域下的按钮应

用于该区域中的选定项目。 您可以通过 View » 

Workspace Panels » SCH » SCH Library 或 

Altium Designer 界面右下角的 SCH » SCH 

Library 找到该面板。 

 器件区 

该区列出了活动库中的所有器件。  

双击器件打开 Library Component 

Properties 对话框。  

使用右键菜单中的按钮和选项管理库。  

 部件区 

Part 按钮用于单步通过多部件器件中的各

个部件。 

 别名区 

该区能为共享同一图形和描述的器件添加

备用名称。 

 管脚区 

该区列出了当前器件的所有管脚。  

可通过双击方式对单个管脚进行编辑。  

选择 View » Show Hidden Pins 显示所有定

义为隐藏的管脚。 此操作不会更改管脚的实际

隐藏/非隐藏状态，它只将在库编辑器中显示隐

藏管脚。 

在使用增量名/符号名放置多个管脚时，先

从菜单中选择 Place » Pin，然后按 TAB 键定义

起始值。 在默认情况下，管脚编号和名称都呈递增情况。  
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递增行为可以通过 Preferences 对话框中的（shematic / gerneral） Auto-Increment during 

Placement 选项控制（初始值为管脚编号）。 要使值递减，可输入负号。 要使值按字母顺序递

增，则输入字母值。 如值为单个字母后加多个数字，则按首字母递增排序。 如果有多个字母，

则按最后一个字母递增或递减。 

当前器件的所有管脚也可在 List 面板中查看或编辑。要过滤器件以仅显示管脚，请在图形

区中单击右键，然后从浮动的右键菜单中选择 Filter » Examples » Pins。 如果 List 面板当前不

可见，可按 Shift+F12 使之显示。 注意：您可以在 List 面板中编辑多个管脚属性，还可以在电

子数据表之间进行复制和粘贴。 

1.1.2   器件属性 

Component Properties 对话框用来为器件符号添加模型和参数信息。 在 Sch Library panel 

中双击器件名字可显示属性对话框。 

 

图 5  器件属性对话框 

可以为器件定义的常见信息包括： 

 默认符号名 ― 定义器件符号名使用的前缀字符串。 

 注释 ―― 器件的描述。 对于具有固定定义的器件，如 74HC32，应输入该标准描

述字符串。 对于那些数值可以更改的分立器件，如电阻器，应输入数值。 注意，

本字段支持间接取值，因此可以显示此器件的任意参数值。 输入等号和参数名（不
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能有空格）可启用间接取值功能。 如果此字段保留为空白，则器件库引用信息将在

放置器件时输入在注释中；在将该器件放置到原理图后，您可以对注释进行定义。 

 

图 6  使用 List 面板查看或编辑器件管脚 

 描述 ― 用于搜索和在 BOM 中使用的描述。 

 类型 ― 备用器件类型，供特殊情况下使用。 图形器件在 BOM 中不会同步化或包

括在 BOM 中。 机械类型只有在它们同时存在于原理图和 PCB 中时才会同步，并

且可以存在于 BOM 中。 网连（Net Tie）器件用于短接 PCB 上的两个或两个以上

的网络。 

 参数 ― 库编辑器或原理图中可以添加任何数量的参数。 参数可以链接到公司数据

库；为此只需将数据库链接文档添加到项目即可实现。 

 模型 ― 可添加各种器件模型，包括封装、仿真和信号完整性分析模型等。 

 锁定管脚 ―― 如启用此选项，器件放置在原理图上后，将无法对管脚进行编辑，

而只能对整个器件进行操作。 如要编辑管脚，则需禁用此选项，然后单击 Edit 

Pins 按钮。 

2.31.1.3      练习 ― 创建新的器件符号 

1. 现在我们要创建一个器件 ―― 串行温度传感器。 如果原理图器件库尚未打开，请打

开：\Program Files\Altium Designer 6\Training\Temperature Sensor\ Libraries\Temperature 

Sensor.SchLib 

2. 在创建器件前，首先将此库导入温度传感器项目。 如果该项目尚未打开，请重新打开打

开在 Environment and Editor Basics 培训阶段创建的项目： \Program Files\Altium Designer 

6\Examples\Training\Temperature Sensor\Temperature Sensor.PrjPcb 

3. 要将库添加到项目中，单击 Projects 面板中的 Temperature Sensor.SchLib 并按住不放，

将它拖动到项目文档名称上。Temperature Sensor.PrjPcb. 会从 Free Documents 中消失，而出现

在项目框架的 Libraries 文件夹图标下。 

4. 在项目名称上单击右键，选择 Save Project。 

5. 要创建新的器件，选择 Tools » New Component。 
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6. 在 New Component Name 对话框中输入 TCN75。 

7. 出现空白图纸时，按 PAGE UP 键放大，直到看到网格。 器件体的左上端通常位于坐标原

点 0,0（以两条深色网格线表示）。 

8. 检查 Snap Grid  和 Visible Grid 是否设置为 10（Tools » Document Options）。 

 

图 7  微芯片  TCN75 串行温度传感器 

9. 为图 7 所示的器件创建图形表示。器件体为长方形，放置在图纸正中原点处。 原点为两

条暗色网格线构成的十字准线交点，可放大/缩小显示十字线和网格线。 放置长方形时从原点

开始，器件体为 80 单位宽 x 70 单位高，您可以使用 Status bar  上显示的坐标来引导。 

10. 为部件放置管脚。 要注意管脚方向，高电位端须远离器件体。 放置管脚时，光标应位于

管脚的高电位端。 按 SPACEBAR 键旋转管脚或按 X 或 Y 进行翻转。 

11. 在放置管脚前，按 TAB 键编辑管脚属性。Pin Properties 对话框将会打开。 记住： 

检查管脚数是否正确以及管脚长度设置是否恰当（如 20）。 

根据下表设置电气类型： 

管脚数 管脚名称 电气类型 

1 SDA IO       

2 SCL Input     

3 INT/CMP Output     

4 GND Power     

5 A2 Input     

6 A1 Input     

7 A0 Input     

8 VDD Power     

12. 完成器件绘图后，设置： 

- 符号名为 U？  

注意： 放置管脚 5、6

和 7 时使用自动递增/

递减功能。 
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- 注释为 TCN75 

- 描述为 Serial temperature sensor 

此时，此器件仅仅是一个符号，它没有模型或参数 ― 它应至少需要有一个封装。 你可以

在下一阶段为此器件创建一个封装，然后回到原理图器件库编辑器把它链接到符号。 
 

1.2 PCB 库编辑器及创建元件封装 

PCB Library Editor 用于创建和修改 PCB 器件封装，管理 PCB 器件库。PCB Library Editor 

还提供 Component Wizard，它将引导您创建通用的 PCB 器件类型。 

1.2.1   PCB Library 工作空间 

 
图 8. PCB Library Editor 工作空间 

视图命令、图元对象、层、选择与焦点、网格和常用的编辑功能都与 PCB Editor 相同。 

Preferences 对话框与 Board Options 对话框的设置也应用于 PCB Library Editor。 
 
 
 

1.2.2 PCB Library Editor panel 
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PCB Library Editor 的 PCB Library  面板提供操

作 PCB 器件的各种功能，包括： 

面板的 Components 区列出了活动库中的所有器

件。 

在 Components 区中单击右键将显示菜单选项，

您可以新建器件、编辑器件属性、复制或粘贴选定器

件，或更新开放 PCB 的器件封装。 

请注意右键菜单的 copy/paste 命令可用于选中的

多个封装，并支持： 
 在库内部执行复制和粘贴操作； 

 从 PCB 复制粘贴到库； 

 在 PCB 库之间执行复制粘贴操作。 

Components Primitives 区列出了属于当前选中

器件的图元。单击列表中的图元，在设计窗口中加亮

显示。 

选中图元的加亮显示方式取决于面板顶部的选

项： 
 启用 Mask 后，只有点中的图元正常

显示，其他图元将灰色显示。单击工

作空间右下角的  按钮将删除过

滤器并恢复显示。 

 启用 Select 后，您单击的图元将被选

中，然后您便可以对它们进行编辑。 

在 Component Primitives 区右键单击可控制其中

列出的图元类型。 
 

 

1.2.3    使用 Component Wizard 创建器件 

PCB Library Editor 带有 Component Wizard。通过此向导，用户可以选择不同的封装类

型，填写相应的信息，然后将生成器件封装。 

要启动 Component Wizard，右键单击 PCB Library Editor 面板的 Components 区，选择 

Component Wizard，或者选择 Tools » New Component。 

图 9. PCB Library 面板 
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1.2.4    使用 IPC 封装向导创建器件 

IPC Footprint Wizard 用于创建 IPC 器件封装。IPC Footprint Wizard 不参考封装尺寸，而是

根据 IPC 发布的算法直接使用器件本身的尺寸信息。 

当 PCB Library 是活动文档时，通过 Tools » IPC Footprint Wizard 菜单，可打开新的 IPC 

Footprint Wizard 来创建 IPC 器件封装。 

根据 IPC 标准，它还支持 3 种封装变量以满足板卡密度要求。该向导支持 BGA、BQFP、

CFP、CHIP、CQFP、DPAK、LCC、MELF、MOLDED、PLCC、PQFP、QFN、QFN-2ROW、

SOIC、SOJ、SOP、SOT143/343、SOT223、SOT23、SOT89 和 WIRE WOUND 封装。 

 

-图 10. IPC Footprint Wizard 中支持的其中一个新封装就是 DPAK（Transistor Outline）. 

IPC Footprint Wizard 的功能还包括： 

 整体封装尺寸、管脚信息、空间、阻焊层和公差在输入后都能立即看到。 

 还可输入机械尺寸如 Courtyard、Assembly 和 Component Body 信息。 

 向导可以重新进入，以便进行浏览和调整。每个阶段都有封装预览。 

 在任何阶段都可以按下 Finish 按钮，生成当前预览封装。 

1.2.5     使用 IPC Footprints 批处理生成器创建器件 

当 PCB 库是活动文档时，通过 Tools » IPC Footprint Batch Generator 菜单，IPC 

Footprint Batch Generator 可以快速生成多个封装，并通过包含封装信息的输入文件生成多密

度单器件。 
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图 11. IPC Footprint Batch Generator 选项可选择在当前开放的 .PcbLib 中创建所有器件，或

根据输入文件或封装名称生成单个.PcbLib 文件。 

IPC Footprints Generator 的支持包括： 

 可在对话框中打开安装目录 \Templates 文件夹下提供的封装类型空白模板文件。另

外还提供封装类型模板的帮助信息。 

 封装输入文件只需包含单个封装类型的一个或多个封装信息，文件格式可以是 

Excel 或以逗号分隔（CSV）。 

1.2.6   手动创建器件 

在 PCB Library Editor 里使用 PCB Editor 中相同的图元对象来创建器件。除了 PCB 器件

外，转角标记、机械定义等等也可保存为器件。 

手动创建器件封装的常见顺序是： 

 在 PCB Library Editor 中打开想要的库。 
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 选择 Tools » New Component 菜单命令。您会看到一个空的器件封装工作空间，称

为 PCBComponent_1。双击 Components 列表中的名称对该器件重新命名，选择 

Component Properties 在 Component Properties 对话框中输入新名称。器件名称的

字符数最多不超过 255 个。 

 使用线轨或其他图元对象把器件轮廓放在 Silkscreen 层。 

 根据器件要求放置焊盘。在放置第一个焊盘前，按下 TAB 键定义所有的焊盘属性。

请确保指示器的属性设置正确。一般来说，放置的第一个焊盘是管脚 1， 因此将第

一个焊盘的指示器设置为“1”，指示器会自动增加。 

注：0,0 坐标点是放置过程中器件的“保持”点。确保将其设定到合适的位置。可以选择 

Edit » Set Reference 改变该位置。 

1.2.7 复制器件 

通常需要将器件从一个库复制到另一个库或在同一个库内进行复制。对于单个器件，您可

以使用 Edit » Copy Component 命令。该命令拷贝当前器件，并准备粘贴到某个 PCB 库中。 

您也可以使用 PCB Library 面板的右键菜单命令拷贝/粘贴多个器件。按住 Ctrl 并单击选择

列表中需要的器件封装，然后右键单击选择 Copy，再次右键单击，选择 Paste X Components 

（X 是您选择的器件封装数）。 

1.2.8    Library Editor 中的特殊字串 

Library Editor 中有两种活动的特殊字串。您可以用来控制指示符（.Designator）和注释

（.Comment）的位置。 

相对于将要放置指示符或注释的器件的位置，将这些字串放在 PCB Library Editor 的工作空

间中。 

使用过程中，您可以隐藏在 PCB 文件中放置器件时添加的缺省指示符和注释。 

1.2.9 练习– 创建器件封装 

在本练习中，我们将创建新器件封装 SOIC8，以使用您刚刚创建的 Temperature Sensor 器

件 TCN75。 

首先需要封装库。在培训中，我们将在项目库中创建封装。如果没打开，请打开封装库：

\Program Files\Altium Designer 6\Training\Temperature Sensor\ Libraries\Temperature 

Sensor.PcbLib。 

1. 创建封装以前，我们将把该封装库添加到 Temperature Sensor 项目。如果没有打开，重新

打开我们在 Environment and Editor Basics 培训中的项目 \Program Files\Altium Designer 

6\Examples\Training\Temperature Sensor\Temperature Sensor.PrjPcb。 
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2. 要将库添加到项目中，单击 Projects 面板中的 Temperature Sensor.PcbLib ，然后将其拖

动到项目名称 Temperature Sensor.PrjPcb。项目将在 Free Documents 中消失，而会在对象结构

中的 Libraries 文件夹图标中显示。 

3. 右键单击项目名称，选择 Save Project。 

4. 使用封装向导创建 SOIC8 封装，选择 Tools » IPC Footprint Wizard 运行 Wizard。 

5. 在模式类型列表中，选择 Small Outline Packages（SOP），如图 12 所示。 

 

-Figure12. 在 IPC Footprint Wizard 中选择封装类型 

6. 参考图 13 的尺寸信息。请注意向导完成时将创建 8 个圆角焊盘。 

 
-图 13.SOP 封装尺寸. 
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7. 逐步通过 Thermal Pad dimensions、Heel spacing、Solder fillets、Component Tolerances 和 

IPC Tolerance。 

8. 在 SOP Footprint Dimensions 页，将焊盘形状改为 Rectangular. 

9. 在 SOP Silkscreen Dimensions 页面将 silkscreen 线宽改为 0.1mm. 

10. 进入 Courtyard, assembly and component board information 页面。 

11. 在封装 Description 页面，将名字改为 SOIC8，描述保持不变。 

12. 在 Footprint Destination 页面，把现有 PcbLib 文件设置为 \Program Files\Altium Designer 

6\Training\Temperature Sensor\ Libraries\Temperature Sensor.PcbLib 

13. 单击完成，结束向导并创建如图 14 所示的新器件。 
 

 
图 14.完成 temperature sensor.pcblib.中的封装创建 

14. 保存库和项目。 
 

 

1.2.10     浏览封装库 
• 单击面板顶部的  按钮并选中 Footprints 复

选框，以此启用封装显示模式。 
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• 在下拉列表中选择库名称，该库中的所有封装都将显示。库可以是集成库，也可以是封装

库。 

• 活动项目中的封装库、当前安装的封装库或搜索路径上的封装库都可以在面板中找到。 

• 单击面板顶部的 Libraries 按钮安装封装库。 

• 库的搜索路径在 Options for Project 对话框 的 Search Path 标签中规定。 

• 要搜索某个封装，首先启用 Footprints 模式，然后单击 Search 按钮。                                           

图 15. Libraries 面板 

• 单击列表中的封装名称，以在 MiniViewer 中显示该封装。                                                                              

• 单击 Place 按钮或双击封装名称将选定封装放在工作空间中。 

1.2.11   用不规则焊盘形状创建封装  

有时候您需要创建带有不规则形状的封装。您可以使用库编辑器中的任意设计对象完成，

但有一个重要因素需要考虑。 

 软件会自动根据焊盘对象创建阻焊层和助焊层，如果您使用焊盘对象构建不规则形状，那

么将生成正确的、匹配的不规则屏蔽形状。如果您通过其他对象如线（轨）、填充、区段或者

弧线生成不规则形状，那么您还需要定义阻焊层或助焊层，方法是将经过适当扩展或压缩的对

象放在阻焊层和助焊层上。 

 图 17 和图 18 是不同设计师创建的各种 SOT-89 封装版本。图 17 使用 2 个焊盘在中心创建

大型不规则形状焊盘，图 18 使用焊盘和线（轨）。图  需要手动定义阻焊层和助焊层。 

 

图 17. 使用焊盘创建不规则形状 
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图 18. 使用线轨创建不规则形状 
 

1.3 元件参数介绍以及链接相关文档  

1.3.1   器件参数 

您创建的每个器件都可以有任意个器件参数，在库或者原理图上可以对参数进行添加/编

辑。参数可用于您所需的任何目的，包括： 

 器件细节信息，如额定电压、器件版本等等； 

 公司器件信息，如股票代码或价格； 

 设计参考信息，如特定的装配要求； 

 与参考信息的链接，如站点和 PDF。 
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图 19 添加参数，充分描述器件。 

任何器件参数都可以放进 Bill of Materials，或者您通过 Report 生成对话框生成的客户报

告。 

 

图 20 生成报告，包括您需要的任何器件数据。 

1.3.2    练习 – 添加器件参数 

要添加的有用器件参数是从原理图器件到数据表的链接。串行温度传感器器件有一个 PDF 

数据表单，现在我们添加一个参数，可以直接从原理图打开数据表单。 

1. 在 Windows File Explorer，确认有 PDF 数据表单。访问： C：\Program Files\Altium 

Designer 6\Examples\Training\Temperature Sensor 

2. 在 Windows File Explorer，拷贝此地址位置（您可能需要先通过 View » Toolbars 菜单启

用 Address Bar）。 
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3. 回到 Altium Designer，然后在库编辑器中 TCN75 器件符号打开的情况下，在 SCH 

Library 面板双击其名称打开 Library Component Properties 对话框。 

4. 在对话框的 Parameters 区域，单击 Add 按钮添加新参数，打开 Parameter Properties 对

话框。 

5. 在 Name 域，输入 HelpURL。 

6. 单击并将光标放在对话框的 Value 域，然后将从 Windows File Explorer 的 Address Bar

拷贝的地址粘贴到 Windows 剪切板，即：C：\Program Files\Altium Designer 

6\Examples\Training\Temperature Sensor 

7. 在字串最后输入反斜线符号（‘\），然后输入 PDF 名称，即： TCN75 - 21490b.pdf，如图  

21 所示。 

 

图 21. 添加 HelpURL 参数，将数据表链接到器件 

8. 由于原理图上无需显示该字串，因此在 Parameter Properties 对话框中不要选中 Visible 

复选框。 

9. 单击 OK 关闭对话框，然后单击 OK 关闭 Library Component Properties 对话框。 

10. 保存库。 

现在可以在原理图表单上使用新的器件符号，检查封装和参数。 

1.4 参数管理器以及编辑参数信息 

1.4.1    添加和修改器件参数  

参数可以添加到原理图库编辑器或原理图编辑器中的单个器件。在库级别添加参数可确保

器件信息的一致性，加快器件放置过程，这样器件就不需要单独添加。 

Altium Designer 也提供强大的 Parameter Manager ，可以把参数全局地添加到库、原理图

或系列原理图。 

打开 Parameter Manager： 
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在 Schematic 或者 Schematic Library 编辑器，从菜单选择  Tools » Parameter Manager 启动

Parameter Editor Options 对话框。 

启用需要的 Include Parameters Owned By 复选框，如果您正在编辑器件，那么一般只有 

Parts 选项，然后单击 OK。 

Parameter Table Editor 将会打开。栏目的标题与参数名相对应，每栏的内容与参数值相对

应。图 22 显示的就是 Parameter Table Editor。 

     

图 22. Parameter Table Editor 

右键单击 Parameter Table Editor 可显示选项，如 Add Columns、Add Parameter Values、

Copy、Paste 等等。也可以从标准文本和多数数据表单应用程序如 Microsoft Excel 粘贴数据。 

所有参数更改都由 Engineering Change Order（ECO）流程控制，该流程可控制 ECO 的执

行，可以有选择地引入和删除操作，在执行前生成所有更改的报告。 

1.4.2    练习– 在 Parameter Manager 中编辑参数 

1.a) 从 Temperature Sensor.schlib 原理图库选择 Tools » Parameter Manager ，在初始对

话框中，确保只有顶部 Include Parameters Matched By 字段中的 Parts 选项被选

中，其他选项保持为缺省设置。 

2. 在 Parameter Table Editor 中，右键单击选择 Add Column。 

3. 在 Name 域，输入 Lead Time，勾选 Add to all objects 选项。让 Value 域保持空白，然

后单击 OK。新的栏目将创建出来，对话框的右边沿显示 Lead Time 标题。 

4. 右键单击 DMC-50448N 器件的 Lead Time 栏内容，选择 Edit。该域将变为带有光标的

下拉框，输入 14 days 。 

5. 右键单击 PWR2.5 器件的 Lead Time 栏内容，选择 Edit。现在可以从下拉框中选择以

前输入的文本。 



Module 3: Schematic Editor Basics 0 - 20 

6. 对于器件 PWR2.5  右键单击以前的 Lead Time 域，并选择 Copy，然后右键单击器件

TCN75 的域 Lead Time 并选择 Paste。 

7. 用 Ctrl+Click、Shift+Click、或者拖动选择内容域来选择 Lead Time （不包括该栏的标

题）栏的整个内容。右键单击，然后选择 Edit，3 个单元格中只有一个显示为可编辑。输

入文本“3-5 Days”并敲击键盘上的 Enter 键。 

8. 单击 Accept Changes（Create ECO）打开 Engineering Change Order 对话框。这是将要

应用到库的修改列表。请注意可以禁用单个修改。 

9. 单击 ECO 对话框中的 Execute Changes 按钮，在设计中应用修改。Report Changes 按

钮可生成修改顺序列表，如果您需要记录对设计文件的修改，可以使用该顺序列表。 

10. 保存库。 
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2.   添加模型信息到元件                 (20 minutes) 

2.1  添加模型及模型管理器 

2.1.1     添加模型 

有许多方法添加器件类型，包括： 

 通过 Library Component Properties 对话框 

 通过主工作空间底部的类型区域 – 如果不可见，单击工作空间右下侧的向下小箭

头。 

 通过 Model Manager。Model Manager 可以同时为多个器件添加多个模型，这对跨

库查看指定模型十分理想。 

 

图 23.在编辑窗口底部或者在 Model Manager 中添加并管理器件类型 

2.1.2    练习–使用 Model Manager 添加封装 

使用 Model Manager 添加封装： 
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1. 如果还未打开，请打开 Temperature Sensor 项目（\Program Files\Altium Designer 

6\Examples\Training\Temperature Sensor\Temperature Sensor.PrjPcb）。 

2. 在 Projects 面板，浏览并打开原理图库： Temperature Sensor.SchLib。 

3. 在 Schematic Library Editor 中选择 Tools » Model Manager 打开 Model Manager。显示

当前库中所有器件的列表以及任意模型，包括 Footprint、Simulation、Signal Integrity 和 

PCB 3D 的模型。 

4. 在 Model Manager 对话框，单击您创建的 TCN75 器件，使之成为活动的部分。 

5. 单击 Add Footprint 启动 PCB Model 对话框，如图 24 所示。 

 

图 24. 为器件添加封装类型 

6. 如果您知道封装名称并且确信它就在当前可用封装库中，那么您可以直接在 Name 域

中直接输入名称，如果找到就会有图像显示，如果没有显示，您可以单击 Browse 打开 

Browse Libraries 对话框，如图 39 所示。 

注： 有许多不同方法可以从符号找到封装，这由 PCB Model 对话框中的 PCB Library 区

决定。Any 指在任何当前可用库中找到封装， Library Name 指必须来自特定的库，Library 

Path 指必须来自特定位置的特定库，如果您已经把该库编译进集成库，那么将自动设置 Use 

from integrated。 
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图 25. 使用 Browse Libraries 对话框直观地选择正确封装。 

注： 对话框顶部的 Libraries 下拉菜单可从可用的封装库中选择您当前浏览的库， Find 按

钮可用来搜索，这将在 Schematic Capture 培训模块中演示。 

7. 一旦查找到了新的 SOIC8 封装，选中它后，它会出现在 PCB Model 对话框中。单击 

OK 关闭该对话框。 

注： 如果封装编号方式与符号上的管脚编号方式不同，那么您需要定义从管脚到焊盘的映

射，单击 PCB Models  对话框中的 Pin Map 按钮完成。 

8. 单击 Close 关闭 Model Manager，现在您已把 SOIC8 封装分配到了 TCN75 器件。 

9. 保存库。 

2.2 创建集成库 

我们生成了原理图库和 PCB 苦，而且所有的模型链接到原理图器件库。 现在，我们可以

连接所有的库来生成一个集成库。 

如果您有已创建的现有原理图 /PCB 库，那么这将十分简单。所以我们要做的是进入 File » 

New » Project » Integrated Library，创建 Integrated Library。 

在这里，我们可以简单的拖放 schematic/PCB/PCB3D l 库到这个新生成的集成库中去。 
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图 26. 拖动的原理图/PCB/PCB3D 库现在处于集成库中。 

现在创建扩展名为.INTLIB 的集成库，在 Projects Panel 右键单击 integrated library package 

并选择 Compile Integrated Library。在此处 Altium Designer 把附加到原理图符号的所有模块链

接到一起，包括 Signal Integrity 和 Circuit Simulation，后者没有与本例一起放入一个库文件中。

该库文件可以包括 几百甚至几千个不同文件。 

这样做有几个好处, 

 集成库大小通常是原有文档的 1/8 到 1/10 。 

 随着项目变得越来越大，集成库完成诸如库更新、PCB 更新等任务的速度将越来越

快。换句话说，它的容量将大大增加。 

 集成库可以放到网络驱动器上在整个公司内使用。该文件也可以放在用户权限有限

制的驱动器上，这样只有特定用户，如库管理员，才能编辑它。 

 与非集成库相比，集成库更容易从库中添加和删除。 

　和其他事情一样，这样做也有缺点：编辑集成库时，需要将库解压缩到单个文件中。如

果管理不正确，这个流程将十分混乱。 

编辑集成库时，需要如上所述将库解压缩到单个文件中。您只需打开 .INTLIB 文件，它就

会询问您是否需要解压缩，如图 27 所示。 
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图 27 尝试打开集成库时弹出的对话框。 

单击 Extract Sources 您将看到如图 28 所示内容。

 

图 28 解压缩集成库 miscellanous devices 结果 

请注意，只显示 schlib 和 pcblib 文档，当您浏览库接压缩到的目录时，将会看到有许多电

路仿真模型如 ckt  和 mdl 。如果有 PCB3D 模型，那么也会显示在该目录中，但不会出现在 

Projects Panel 中。 

对集成库中的文档进行编辑后，您只需右键单击 Projects Panel 中的 LIBPKG 项目，然后

和创建时一样选择编辑操作。如果集成库没有在使用，那么这将修改已创建的集成库。 

您也可以设置集成库的创建目录，进入 Project » Project Options » Options Tab 并设置相

应的输出路径。 
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3.  完成原理图设计并更新器件         (45minutes)              

随着可以在 Altium Designer 当中可以编辑器件的便利性，如果修改不理想，这也带来了

一些风险。  这个功能会检查图中的器件相对于库做出的修改 ，并且会产生一个报告  

3.1 更新器件信息到原理图 

原理图部件的比较通过原理图编辑器中的更新工具进行。 

对照器件原先所属的库进行检查，如果没有相关库或者器件应对照其他库进行比较，则需

要更新器件的库属性。 

 

图 29. 从原理图库到原理图的更新 

 从 Tools » Update From Libraries  打开 Update 对话框。 

 不要选择 Fully replace symbols on sheet with those from library 设置。 

 在如何处理参数差别方面， Advanced 按钮可以提供更大的灵活性。 

 单击 Finish 

 如果 Engineering change order 对话框显示系统检测到差异，单击 Report Changes 按

钮生成打印报告。 

 可能最好不要执行 ECO 更改。 
 



Module 3: Schematic Editor Basics 0 - 27 

 

图 30. Engineering change order 对话框列出找到的所有可执行差异 

一些 ECO 更新是有效的，而且也是我们所期望的。一般，通用的器件保存在库中，在放置

时进行定制。例如，可能库中有一个单个电容器件，一旦放置则值参数将被编辑。从库对话框

的第二个 Update 屏幕中排除这些器件检查可能比较值得。所以 ECO 生成具有不同参数或注释

属性的器件列表，是否检查可能不十分关键。 

关键差异如：  

 Model Values（封装或管脚映射差异） 

 Part Symbol（管脚属性差异） 

每个不同器件都有其唯一的原理图库部件，例如，在电容器库中每个可能的电容器值都有

单独的符号，更新检查到的任何差异都很重要。 

注：要比较从一个库放置与从其他库中放置的器件，使用 Parameter Manager （在 Tools 菜

单中）。编辑系统参数调用库时必须十分小心，因为可能需要其他编辑操作才能恢复。 

3.2     更新器件封装 

PCB 封装的比较通过 PCB 编辑器的更新工具完成。 

检查封装图元与 PCB 库的差异，比较特定的原理图对应部件或者器件的库属性。如同原理

图部件检查一样，PCB 封装库也要能得到才可以。 

 Tools » Update from PCB Libraries 

 设定期望单位和公差。此处的 imperial 和 0.001 mil 缺省设置能够满足多数情况，然

而如果您处理的是以前发布的设计，那么需要调整公差值，以避免显示不重要的差

异。 

 选择要比较的层。在某些情况下只有信号层的差异比较重要。 

 Create Report 按钮可以生成 HTML 报告。 

 不希望在检查差异之前就处理 ECO 。 
 



Module 3: Schematic Editor Basics 0 - 28 

 

图 31. 从 PCB libraries 到 PCB 的更新。这将显示所有物理差异，生成需要更改的 ECO。 

注：在更新时，如阻焊层扩展和助焊层扩展发生变化，请注意，PCB 本身的设计规则可替

换库中的设置。因此，即使您从库进行更新，PCB 设计规则也将修改通过该流程所做的更新。 

实际上直接从 PCB 编辑器（通过打开器件图元）编辑封装的作法十分少见。导致差别的最

常见原因就是封装来自错误的库，或者来自库级别过期的封装变化。在任何情况下都要仔细考

虑这些差别，更新后需要通过 Batch DRC 确认这些更新不会危及 PCB 版图的完整性。 
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4. PCB 基础编辑                      (30 Minutes)  

当您开启或建立 PCB 文件时，PCB 编辑器即会开启，它分享所有 Altium Designer 环境中提

供的工作区功能。 

PCB 编辑器的用途是与电路图编辑器一致的，在以下部份介绍其它额外的功能： 

 

Figure 31 PCB 编辑器工作区 

一个 PCB 电路板是由好几组图层所组合而成，包括镀铜的电气层、机械层、屏蔽层、丝印

层(文字层)。连结每一个图层位于 PCB 编辑器设计窗口的底层边缘处的标签，它们允许你去切

换现在的图层与正在被使用的图层(高亮显示的卷标)给予可视化的指示。如果有更多的图层卷

标能够被显示在同一时间，可以使用滚动条的方式卷动标签，图层的颜色将会被显示在图层卷

标的右侧并且连点两下会开启电路板图层与颜色对话框。 

 
 

4.1 View 指令 

View 指令可在 View 菜单中或主要工具列中被选取，以下表格列出主要的 View 指令： 

Menu Command Toolbar Shortcut 快速键 Description 描述 

Fit Document  VD 适当显示在目前文件窗口中所有的对象 
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Fit Board  VF 适当显示在目前 Board 窗口中所有的对象 

Area  VA 适当显示经由所框选方形区域内的所有对象 

Around Point  VP 适当显示经由所框选方形区域内的所有对象 

View Selected Objects  VE 适当显示在目前文件窗口中被选取起来的对象 

View Filtered Objects  VE 在目前文件窗口中适当显示所过滤的对象 

Zoom In  VI 在光标所在位置放大 

Zoom Out  VO 在光标所在位置缩小 

Zoom Last  VZ 在最后的 view 指令前回复显示它的状态 

Refresh  VR 刷新 (重画) 屏幕 

Table 1. View 指令一览 

接下来的快速键对于文件窗口的操作是非常有用的，这些快速键能够随时使用，甚至是正

在执行命令中。 

Keystroke Function 功能 

End 刷新(重画)屏幕 

Alt + End 刷新(重画)目前的图层 

Page Down 缩小视图(维持目前光标位置) 

Page Up 放大视图(维持目前光标位置) 

Ctrl + Page Down 观看文件 

Ctrl + Page Up 在目前光标位置处做大幅度的放大 

Home 自动边移 (目前光标所在位置移动到屏幕画面中央) 

Arrow Keys 在箭头所指方向用一个快速格点移动光标 

Shift + Arrow Key 在箭头所指方向用 10 个快速格点移动光标 

Table 2. PCB 观看操作的快速键 

 Autopanning  

当执行功能命令时执行自动边移改变，即当光标出现十字交叉的型态。在这个状态下，只

要碰触到窗口文件文件的任何一处边缘，将会执行自动编移的功能。 

自动编移的速度是可以被控制的，藉由在参数设定中自动编移的选项(Tools » Preferences)。     

自动编移也可以在这边进行关闭的设定。 

 Right mouse panning 

你也可以使用鼠标右键来浏览你的 PCB 文件。 

1. 请将光标放置在 PCB Editor 工作区域中。 
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2. 按压鼠标右键使得光标显示为一只小手的样式。 

3. 移动光标可搬移图纸到想要观看的位置。 

Note： 一旦游标释放离开，你将需要重复此过程步骤。 

 Displaying connection lines 

在 View » Connections 功能菜单中，设定允许显示或者是隐藏单条 Net、零件的 Net 或者是

版子上的所有 Net 的鼠线。 

4.2 选择（Selection） 

使用选择的功能，对对象图标进行编辑。下面是关于使用选择使用的一些要点： 

 当点击鼠标左键时可将对象选取。 

 将被选取的对象按压鼠标左键可以允许移动它。 

 通常在单击的情况下是赋予移动处理的能力。 

 可连续放置对象。 

 只要在工作区域中没有对象的地方进行点击，即可除选对象。 

Note: PCB 零件不能被编辑，除非解开零件的锁定。零件包装通常只在 PCB 零件库中进行

编辑。 

PCB 编辑对应在 Windows 其它应用程序中的选择，功能虽然不尽相同，但提供相似的选择

功能。  

下面是一些关于在 PCB 编辑器里进行选择操作的要点： 

 选取的物体可以剪下或者复制到剪贴板中，并且能在当前的 PCB 文件或者是在另一

个 PCB 文件上选择贴上。 

 有许多 PCB 编辑指令针对被选取的对象。例如：Tools » Interactive Placement 指令。 

 PCB 编辑中使用可支持 PCB 数据，一块特别专有的剪贴板。当执行复制的操作功

能，图件也同时被放置进 Windows 的剪贴板中，可以在另一个 Windows 的应用程序

中进行粘贴。 

选取对象，你可以使用下列方式： 

Method 方法 Function 功能 

Click and drag box around 选取在框选范围内的对象 

Shift + Click 选取不同的对象           (针对被选取的对象使用可以进行除选)

Edit » Select menu (S)  选择 Inside Area(区域内)、Outside Area(区域外)、Touching 

Rectangle(框选方形区域内)、Touching Line(碰触到的线段)、

All(全部)、Board(板框内)、Net(网络)、Connected Copper(单层

有连接的铜箔)、Physical Connection(图件的联接)、Component 

Connections(单层零件关联的连接)、Component Net(零件关联的

Net)、Room Connections(Room 关联的连接)、All on Layer(该层

面全部)、Free Objects(Free 对象)、All Locked(所有锁住的对

象)、Off Gird Pads(零件 Pad 不在格点上)、Toggle Selection 
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Select Inside Area 选取范围区域内 
在主要工具列上的 按钮 

Table 3 选取指令一览表 

 

Function 功能 Menu command 指令菜单 Shortcut keys 快速键 

Cut 剪下 Edit » Cut Ctrl + X 

Copy 复制 Edit » Copy Ctrl + C 

Paste 贴上 Edit » Paste Ctrl + V 

Delete 删除 Edit » Clear Ctrl + Delete 

Move 移动 Edit » Move » Move Selection Click-and-hold 

Rotate 旋转 Edit » Move » Rotate Selection Spacebar 

Flip 翻面 Edit » Move » Flip Selection X or Y 

Align 对齐 Tools » Interactive Placement » Align A (Align Submenu) 

Jump to 跳耀至 Edit » Jump » Selection J (Jump Submenu) 

View 视图 View » Selection Objects V (View Submenu) 

Convert 转换 Tools » Convert T (Tools Submenu) 

Table 4 选择的对象指令一览表 

除选对象，执行功能菜单 Edit 项目中的 DeSelect 指令一览，或者是在主工具列中的

DeSelect All 图示。 

 

4.3 其它鼠标动作 

Mouse 操作列表，普遍的在 PCB Editor 中被使用。 

在功能菜单中的 preference。 

Mouse Operation 鼠标操作 Function 功能 

Double-click 双击 改变对象 

Click 单击 输入 

Right-click 右键 跳出 

Table 5 一般鼠标快键一览 

4.4 Jump 菜单 

Jump 功能菜单提供光标位置的相关指令。 

Jump 子菜单指令描述如下： 

Menu Command 菜单指令 Shortcut 快速键 Description 描述 

Absolute Origin JA 
光标跳至绝对坐标位置上                     (执行

Ctrl + Home 键也能如此) 

Current Origin JO 
光标跳至相对坐标位置上                        (执行

Ctrl + End 键也能如此) 

New Location JL 光标跳至指定的坐标位置上 

Component  JC 光标跳至指定的零件位置上 
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Net  JN 光标跳至指定的 Net 位置上 

Pad  JP 光标跳至指定的 Pad Number 位置上 

String  JS 光标跳至指定的字符串上 

Error Marker  JE 跳耀至 DRC 错误位置上 

Selection JT 跳耀至选取起来的零件并且作缩放动作 

Table 6. Jump 指令功能一览 

假如执行 Jump 指令没有跳至正确的坐标位置，缩放显示配合改正。 

4.5 总结以及其他板级洞察功能 

4.5.1    PCB 编辑其他新功能 

总之，PCB 编辑部分提供了非常多的新功能，以上介绍只是一些基本功能。另外，在

PCB 编辑时还提供了一些方便设计者编辑及查看的新功能。比如： 

提供 Board Insight
TM

功能 

具备了 Board Insight™ 功能后，就可以用简单、易用的格式显示 PCB 设计中的更多信

息。当在设计导航模式下，高级显示功能将在光标处动态显示出对象的最新信息。Board Insig 

ht 功能使得在复杂、密集、多层设计中浏览对象容易很多。  

 

翻转并编辑板卡 

AD 支持翻转板卡设计功能，真正实现了对 PCB 板的双面布局布线；利用翻转板卡设计功

能，用户在对 PCB 板的双面布局时不再有任何差异，这就简化了对高密 PCB 版图设计工作。 

 

支持 True Type 字体 

AD 提供了对在 PCB 上使用符号字符和 Unicode 字符集的支持，如希腊文、中文和日文语

言字符集；还实现了将字体嵌入到 PCB 文件中的功能，从而满足在不同计算机间的设计可移植

性。 
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4.5.2  PCB 基础练习 

1. 开启 PCB 范例文件 4 Port Serial Interface.PcbDoc，文件位于 C:\Program Files\Altium 

Designer6\Examples\Reference Designs\4 Port Serial Interface 资料夹中。 

2. 要熟悉的这个部分，透过在表格 9-13 中所列举的 PCB 显示和选择的指令列表。 

3. 试着使用工具列上的指令和快捷键。 

4. 开启 Board Options 设定对话盒，将 Visible Grid 2 关闭，设定 Visible Grid 1 为 50 mil 

并且将 Snap Grid 设为 25 mil。(Design » Board Options) 

5. 放置 Place 菜单指令中的 Fill 项目。退出这指令后使得 Fill 选择状态。在 Fill 对象上

透过单击以进行移动。单击的动作，可选择 Fill 对象内的距点执行旋转，并在旋转动作后

将 Fill 对象进行除选。 

6. 在 PCB 文件，执行功能 View » Fit Document。 

7. 选取零件为浮动状态。基础环境和编辑培训单元 1-49。 

8. 当零件为浮动状态时，按压 Space 键，可以使零件进行旋转(Shift + Space 键可以使零

件作顺时针的旋转)，而按键 L 则可以将零件翻转至背面。 

9. (当零件在背面时，你可能需要开启该层面，才能够看到图件的显示。) 

10. 点击零件并且开始移动它，当移动同时按下 Alt 键，强制零件只能依照按下按键同

时的位置进行水平或垂直的移动。朝着被要求移动的方向进行观察。如果你想要移动一个

组成部分并且保持它的调整，这个特色特别有用。 

11. 选择一区域的零件(利用鼠标框选出一方型区域将那些零件选取起来). 

12. 执行 Edit » Copy 指令功能，复制一区域内的群组零件，并显示在 Clipboard 中。 

13. 别忘记给予参考点位置。 

14. 选择 Edit » Paste 指令功能。Clipboard 中所复制的内容将跳至游标上。当移动该群组

零件时可以使它旋转，再利用点击，将该群组零件放置在要放置的位置上。 

15. 关闭文件并且不储存改变。 
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5.  创建 PCB 设计文件               (30minutes) 

Board Options 对话框 
Board Options 对话框允许你设置 PCB 文档的相关参数。选择 Design » Board Options

菜单命令，打开对话框。对话框中的设置将会在 PCB 文件中保存。  

 

图 32. Board Options 对话框 

 测量单位 Measurement Unit 

设置系统的坐标为公制或英制 
Snap X 设置捕捉网格鼠标水平方向的移动间距 

Snap Y 设置捕捉网格鼠标垂直方向的移动间距 

Component X 设置元件网格鼠标水平方向的移动间距 

Component Y 设置元件网格鼠标垂直方向的移动间距 

 电气栅格（Electrical Grid） 

如果 electrical grid 选项被选中，电气栅格在你放置一个电气对象时工作，它将忽略捕获栅

格而同时捕获电气对象。 

 可视栅格（Visible Grid） 

设置可见网格的尺寸大小和类型 

 图纸位置 Sheet Position 

  可以通过设置此对话框中的 Size 和 Location 来定义图纸的大小，也可以同机械层中的

内容相关联，如果关联到机械层，当机械层的内容改变时，可以使用 Design » Board Shape 

» Auto-position Sheet 命令来重新计算大小。 

关联到机械层有两个比较典型的应用：制版输出时在制图细节方面的应用；不选中

Display Sheet 选项，可以同时隐藏图纸和机械层。 

 标识显示 Designator Display 
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编译时，designator display 既可以显示 logical designator 也可以显示 physical 

designator，通常情况下，这两者是一样的，但在多通道设计中，physical designator 还包括

channel identifier 的信息 

电路板层和颜色 
这个对话框用来设定 PCB 中每一层的显示状态和颜色（快捷键 L） 

 

图 33 电路板层和颜色对话框 

 Signal Layers and Internal Planes 

信号层和内部电源/接地层 

这些层可以在板层管理器中添加或移除，在这个对话框中可以改变它们的显示状态和颜

色。 

Note: Press the accelerator key in brackets () next to the layer name to toggle that layers 

show property while in this dialog 

 Mechanical Layers 

机械层 

总共有 16 个机械层，不选中 Only Show Enabled 可以显示全部的机械层或是添加新的机

械层。按 F2 可以对机械层重命名。 

 Layer Pairs 

层对 
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层对是机械层中关联了处理特殊的器件信息。例如，如果你有一个器件的封装需要胶合信

息，在库编辑时，先在机械层定义好，然后把这个机械层与另外一层成对，当这个封装翻转到

电路板的底层时，第一个机械层的信息就自动转到成对的机械层中。 

 Color Sets 

颜色设置 

Default Color Set 按钮用来将颜色恢复成浅黄色背景的默认设置。如果 Transparent 

Layers（Display 面板）选项选中，Default Color Set 将不可用。Classic Color Set 按键可

以将颜色设置成经典色：黑色背景。 

 Keep-Out Layer 

禁止布线层 

禁止布线层是一个特殊的层，布线层上放置的对象是信号层上放置对象的边界。禁止布线

层通常用来定义诸如电路板的布线和放置器件的边界。或是电路板上必须保持自由器件和布线

的区域。 

PCB 坐标系统 
PCB 编辑界面中有个坐标系统，位于工作区的左下角，用来初始定位。这个点的坐标为

(0,0)，就意味着是绝对原点。工作区的大小为 100*100 英寸。参考点的坐标可以在 Edit » 

Origin » Set 菜单下任何时间重新定义。这种设置为相对原点。坐标通过与相对原点参考读

出。Edit » Origin » Reset 菜单命令可以设置从相对坐标返回到绝对坐标。 

 

初始的标识显示相对原点的位置，这可以在 Display Origin Marker 中显示，坐标单位可

以是英制或公制。在 View » Toggle Units 菜单命令下或快捷键 Q，可以使坐标单位在公制和

英制间切换。 

栅格 
 捕捉栅格 

跳转栅格保证元件精确的移动和放置。跳转栅格使鼠标点击时从一个栅格跳转到设定的最

近栅格点。跳转栅格有 X 和 Y 值，可以在电路板选项对话框中设定，按 G 或 CTRL+G 快捷键

改变栅格。 

 器件栅格 

器件栅格类似于跳转栅格，不过器件栅格只在放置或移动器件时才能激活。器件栅格有 X

和 Y 值，可以在电路板选项对话框中设定。 

 可视栅格。 

可视栅格在打开时可以以线或者点的形式显示。他们是独立的跳转栅格。在 PCB 编辑界面

中有两个可视栅格，你可以在电路板选项对话框中设置，并单独显示。 

 Electrical Grid 电气栅格 
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电气栅格可以被看做为吸引力的范围。在交互式编辑中光标将跳转到任何电气对象上，当

光标处在电气栅格设置的范围内。 

当电气栅格超过跳转栅格，电气中心点在光标下时，光标

处将显示一个八边形，当你看到八边形时，说明光标精确定位

到它要跳转的器件上。 

电气删格的设置，开关可以在电路板选项对话框中设定。

你也可以快捷键 SHIFT+E 调整电气栅格的开关，或者在诸如交

互式布线时通过按住 CTRL 键临时关闭电气删格。 

                                                                                                          图 34.交叉显示电气删格 

5.1 定义 PCB 板外形（由 3D step 文件） 

5.1.1   创建新的 PCB 

有三种方法创建一新的 PCB： 

 执行菜单命令：File » New » PCB，这样可以创建一张 6in×4in 的 PCB 文件。 

 单击 Files 面板 New from Template 栏的 PCB Templates，会出现 Choose 

Existing Document 对话框，有很多模板供选择，模板的名字反映了图纸的大小，

每一个模板文件都有一个默认的版型，通常是 6in×4in。 

 使用向导 Board Wizard，位于 Files 面板的最下面，系统已经为用户提供了一些标

准电路板的标准配置文件，也可以产生简单的 PCB 板外形。 

 

-图 35. 通过 New from Template 创建的 PCB 文件 
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5.1.2 定义电路板的外形和边界 

PCB 板建立后，下一步就是要定义边界，包括电路板的外形、放置元件的边界和布线的边

界。  

 电路板的外形可以通过执行子菜单 Board Shape 中的命令手工定义，也可以通过

选择相应的对象由软件自动定义，例如：可以导入 CAD 文件，根据导入的文件定

义。 

 布线和放置元件的边界由 Keep out layer 层上的闭合的、连续的线来确定（在

5.2.2 中介绍），任何放置在 keep out layer 层上的对象对信号层的对象都起到约束

作用。  

 

Figure36.例子 4 Port Serial Interface 的电路板的外形和边界 

5.1.3 练习—创建电路板的外形和放置元件、布线边界 

给例子创建新的边界： 

1. 显示 Files 面板(View » Workspace Panels » Files)，单击 New from template 部

分的 PCB Templates。 
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2. 在弹出的 Choose Existing Document 对话框中选择 A4.pcbdoc，打开新的 PCb 文

件，如图所示，黑色的区域代表了电路板的外形，现在我们根据 DXF mechanical file 的数

据重新定义其外形。 

3. 执行 File » Import 命令打开 Import File 对话框 

4. 文件类型选择 AutoCAD (*.DXF, *.DWG) 

5. 浏览路径\Examples\Training\Temperature Sensor\Outline.DXF 打开文

件。 

 

图 37. 导入外形文件 

6. 当出现 Import from AutoCAD 对话框时，进行如下设置： 

7. Scale 选择 inch（导入的外形大约是 2021mil x 2755mil) 

8. Layer Mapping：PCB Layer 选 mechanical layer 4 

9. Insertion Point：填入合适的值，例如：X=1000, Y=1000，这些值要求不是很严

格，导入文件后将去掉其他选项默认即可。 

10. 点 OK 按钮，在 Mechanical layer 4 上会出现由四条路径围城的一个矩形。 

11. 现在我们重新定义电路板的形状，从而和导入的外形匹配。选中四条路径。 
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12. 执行命令 Design » Board Shape » Define from selected objects.黑色的电路板形

状将根据导入的外形重新定义。 

13. 移动 PCB 板到 sheet 的中央位置，拖动选中 PCB 板外框和机械层的线条，按“M”

键显示移动 Move 的子菜单，然后选择 Move Selection。点击你选择的部件任何一个的位

置，去定义 PCB 板移动放置的合适位置，接着移动板子的外框和机械层的线条的位置接近

sheet 的中心位置，点击放置。 

Note：为了确定移动的部分保留在选择的工作区，当移动，复制或是黏贴时一般最好选择

一个有意义的点。一般横向和纵向交会的左下方的点比较合适。如果你想对一个对象设定参考

点，确定当前对象在有用层，这样就可把对象移动到有意义的点上。 

14. 将新的板形移至图纸的中心，画一矩形选中板形和机械层上的路径，按 M 键，出现

Move 子菜单，选择 Move Selection，拖动它们到图纸中心，单击放置。 

15. 在 Board Options 对话框中将 Visible grid 2 改为 100 mils。 

16. 定义放置元件、布线的边界。首先取消所有的选定。选中 Mechanical layer 4 上所有

的路径，最简单的方法是使用 select on current layer 命令：将 Mechanical layer 设为当前

层，按 S 键，然后再按 Y 即可选择。 

17. 执行 Edit » Copy 命令 

18. 将 Keep out layer 设为当前层。如果 Keep out layer 没有显示出来，按 L 键打开

Board Layers and Colors 对话框进行设置。 

19. 将复制的部分粘贴到当前层(Keep out layer)：执行菜单命令 Edit » Paste Special，

在 Paste Special 对话框中选中 Paste on Current Layer 选项，点击 OK 返回工作区，将

复制的部分粘贴到 Keep out layer。 

20. 保存 PCB 文件。路径：\Altium Designer 

6\Examples\Training\Temperature Sensor\Temperature Sensor.PcbDoc. 

21. 查看 Projects 面板，如果此 PCB 文件不是 Temperature Sensor 工程的一部分，将

其拖到 Temperature Sensor 工程名下。 

22. 右键单击工程名称，点 Save Project 保存。 

5.1.4 Exercise – Creating a board shape by 3D step  file 

1. 新建一个 PCB 文件。 

2. 点击菜单 Place，选择 3D Body。 

3. 在  3D Body 类型 选择 界面中， 可以选择通用 STEP 模型，如图 38 所示。 
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图 38 选择导入 STEP 模型 

4. 选择 Embeded STEP Model，然后导入 DT02 目录下的一个

bottom_jtag.STEP，进行 3D 显示。 

5. 选择 Design/Board Shape/Define from 3D  body,  用鼠标在 3D  body 上选择

一个平面 ，则自动生成一个板形型。如图 39 所示。 



Module 3: Schematic Editor Basics 0 - 43 

 

图 39  由 STEP 模型来生成 PCB 板形 
 

5.2 设置 PCB 板层结构 

5.2.1    使能层 

在绘制 PCB，放置对象时，首先要考虑放置在那一层上。在 PCB 工作区的底部，可以看

到当前工作在哪一层，对象是放置在当前层上的。  

 可以通过 Layer Stack Manager 对话框添加层 (Design » Layer Stack Manager). 

     

图 40. 在 Layer Stack Manager 对话框中定义相关的层 
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 在 Board Layers and Colors 对话框可以显示和定义非电气层(Design » Board 

Layers & Colors). 

 当前层可以通过以下方式设置： 

 在工作区底部直接点击层的名称，即可将该层设置为当前层。 

 按*键可以在所有信号层之间循环切换。  

 按+ 、–键可以在布线的前后信号层之间循环切换。 

5.2.2 定义层 
PCB 工作层的定义如下： 

 Signal Layers 

信号层 

可以用来布线的信号层有 32 层。信号层主要用来放置元器件和铜膜导线，用导线将各元

器件的引脚进行电气连接，是为电气信号提供通路的层面。信号层命名如下： 

顶层 顶层信号层 

中间层 中间信号层 

底层 底层信号层 

信号层的名字用户可以自定义 

 Internal Planes 

内部电源/接地层 

内部电源/接地层也称为内电层，主要用来铺设电源和地（命名为内电层 1–16），由大块

的铜膜所构成。每一个内部电源层都可以设置一个网络名称，布线时系统会把该层与具有相同

网络名称的图元，如焊盘、过孔等，以顶拉线的形式连接起来。同一个内部电源层可以分成几

个区域，用来安排不同的电源和接地。 

 Silkscreen layers 

丝印层 

包括顶层丝印层和底层丝印层，用于放置一些元器件的外形轮廓和文字信息（元器件描述

的相关信息如设计者、注释等） 

 Mechanical layers 

机械层 

主要用来布置与 PCB 有关的各种说明性标注，如电路板的外形尺寸、焊盘和过孔类型，以

及其他一些制作装配所需要的重要信息等。共有 16 个机械层。机械层的名称可以自定义。根

据实际情况，机械层可以成对使用。 

 Solder Mask 

阻焊层 
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包括顶层阻焊层和底层阻焊层。阻焊层除留出焊点和过孔的位置外，其余部分用阻焊膜将

铜膜导线覆盖住。可以设置规则 Design Rules 控制阻焊膜的大小。 

 Paste Masks 

助焊层 

包括顶层助焊层和底层助焊层。助焊层是在需要焊接的地方图一层助焊剂以增强焊盘的着

锡能力。可以通过 Design Rules 进行相应的设置。 

 Drill Drawing 

钻孔视图层 

提供钻孔位置信息。 

 Drill Guide 

钻孔引导层 

提供钻孔图。钻孔引导层主要是为了与老的电路板制作工艺兼容而保留的钻孔信息。 

 Keep Out layer 

禁止布线层 

用来定义元器件和导线放置的区域范围，它定义了电路板的电气边界，在自动布线的情况

下，元器件和导线必须放置在禁止布线层划定的范围内。 

 Multi-layer 

多层 

代表所有的信号层，在多层上面放置的元器件会自动放置到所有的信号层上。 

 System section 

下面的选项没有实体的对象，它们通过 Board Layers & Colors dialog 对话框中的 System 

Colors 部分开启或关闭。 

DRC Errors ：这个选项控制是否显示自动布线检查错误信息。 

Connections：是否显示飞线 

Pad and Via Holes：是否显示焊点通孔和导孔通孔。 

Visible Grids：是否显示两组格点。 

5.2.3 定义电气图层堆栈 

各个工作层的序号和顺序在 Layer Stack Manager 进行定义 
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图 41 图层堆栈管理器对话框 

Layer Stack Manager 使你可以形象的看到你的 PCB 的层叠，也就是铜，基底，绝缘材料

之间的关系。层叠的显示图片通过点击右键，选择 Copy to Clipboard，被复制到 Windows 剪

贴板中，然后粘贴到工程中。 

1. 添加层 

 添加信号层和中间层 

点击右边的按扭可以添加信号层和中间层，新层添加到选中层的下面（选中的层是最底层

的情况除外），也可以单击右键添加新层。通常的，PCB 板由偶数层构成，可以说任何信号层

和中间层混合而成。在层的名称处右键单击可以重命名、设置厚度、为中间层定义网络名。 

      添加绝缘层 

PCB 增加新的层，绝缘层就会相应的自动添加。绝缘层可以是 Core 或者是 Prepreg，取

决于 Stack Up style 中的设置。 

2. 对工作层的一些操作： 

 属性设置 

双击层的名称，可以修改层的属性，包括名称和物理属性 

 删除层 

单击层的名称，点 Delete 按钮，或单击右键，从弹出的菜单中选择 Delete 命令。 

 修改层的顺序 

单击层的名字，然后点右侧的 Move Up 或 Move Down 按钮，或者单击右键，从弹出的

菜单中选择 Move Up 或 Move Down。 

 编辑层叠方式 

　层叠方式定义 PCB 基板中的顺序， 在 PCB 上完成铜和绝缘材料层的建立。 

通过选择顶层和底层绝缘体的复选框来设置线路板，点击这些来完成材料，厚度和介电常

数的设置 

3. 设置钻孔属性 
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可以对钻孔的起始层和终止层等参数进行设置。默认情况下，钻孔从顶层贯穿到底层。如

果 PCB 中有盲孔或过孔，就需要对它们进行设置。在 Layer Stack Manager 中，点击 Drill 

Pairs 即可弹出对话框。 

 

图 42 如果有盲孔和过孔，定义钻孔属性 

5.2.4 定义机械层 

在 Board Layers and Colors 对话框中可以添加机械层，在使用机械层之前，检查其是否处

于可用状态。  

 不选中 Only show enabled mechanical layers，则所有的机械层都会列出来。在

要添加的新层的 Enable 列打勾，选中 Only show enabled mechanical layers，

可以看到新层已经变为可用状态。 

 更改机械层的名称：点击要更改的名称，按 F2 即可修改。 

 

图 43. 在 Board Layers & Colors 对话框中设置机械层 

 Show 选项决定对应机械层显不显示。 

 选中 Display In Single Layer Mode，当调用 Single Layer Mode 时(SHIFT+S)，将

显示对应的层。 
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 选中 Linked to Sheet，将使对应的机械层与图纸相关联。如果不选中 Board 

Options 对话框中的 Display Sheet 选项，相对应的机械层将不显示；如果不选中

Board Shape 子菜单中的 Auto-position sheet 选项，此选项还可以用来决定图纸

的大小。 

5.2.5 内部电源层 

PCB Editor 最多支持 16 个电源层。 

1. 定义内部电源层 

 在 Layer Stack Manager 中，可以添加、命名电源层并对其分配网络。设置完网络

后，布线时系统会把该层与具有相同网络名称的图元，以预拉线的形式连接起来。  

 在 Layer Stack Manager 对话框中或工作区域双击层，可以为其分配网络。PCB 

Editor 会自动的将网络中的器件的管脚连接起来，将不相关的管脚隔离。 

 层的连接方式在 Power Plane Connect Style 设计规则中定义。在 Power Plane 

Clearance 中可以设定安全距离将层中不相关的网络隔离开来。 

 在 Edit Layer 对话框中可以定义 PCB 边缘的非覆铜区域，在 Layer Stack Manager

中双击层，即可出现此对话框。 

2. 内电层分割 

 内电层可以分成几个区域，由不同的网络共享。  

 通过放置对象（通常是线）可以将内电层划分为几个独立的区域（执行命令 Place 

» Line）。当在内电层放置完线时，系统会自动分析、确定各个划分的区域。 

 放置线的过程中按 TAB 键可以改变线的宽度，线的宽度决定了两个划分的区域间

的安全距离。 

 双击划分的区域可以为其分配网络，同时 PCB 面板的显示模式改为 Split Plane 

Editor。 

 在已经划分的区域里，同样可以进行分割。 



Module 3: Schematic Editor Basics 0 - 49 

 

图 44.内电层分割 

3. 重新定义分割的区域 

通过移动和修改组成这些分割区域边界的对象即可实现重新定义。 

4. 删除分割的区域 

删除组成边界的对象即可实现。 

5.2.6 练习—创建工作层 

1. 在 layer Stack Manager 中创建层。选中层的名称，右键单击，设置相关属性：名

称、铜的厚度。使用相应的按键实现层的添加、删除、上移、下移。 

2. 打开 Board Layers and Colors 对话框，选择要显示的层：Top and Bottom layers, 

Keep-Out Layer, Drill Drawing, Multi Layer and Top Overlay。 

3. 显示和使用 Mechanical layers 1, 4 and 16。不选中 Only Show enabled 

mechanical layers，显示所有的机械层。然后再选中此选项，显示要用到的机械层。使

Mechanical 16 同图纸相关联，这样模板的工程明细表就会在这层上显示出来。 
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6.  将设计更新到 PCB 以及设计同步(45 
minutes)                                                                       

由于不再是通过一个中间网络表文件把设计文件从原理图更新到 PCB 中，Altium designer

在未来将具有强大的设计同步同能。 

6.1 设计同步  

6.1.1   设计同步的工作方式 

 
图 45 设计同步 

同步器的核心特点：: 

•  Difference engine — 比较原理图工程与 PCB。差异比较引擎可以比较出几乎所有类

型文件之间的器件与连接关系的信息。其可以比较原理图工程到 PCB，PCB 到 PCB，网络表

到 PCB，网络表到网络表，等等。差异信息由差异比较引擎找出并显示在差异对话框中。 

•  Difference dialog – 列出文件比较过程中的差异信息。然后你就可以定义哪些文件是

需要同步更新的。允许你在一个单一的更新过程中实现双向的同步过程。右键单击对话框中的

方向选项。 
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•  Engineering Change Order dialog – 一旦差异的更新被确定下来，则会生成一个工

程更新顺序列表。 同时生成对应的报告。 

有以下两种方法来执行更新： 

•  执行菜单 Design » Update 从原理图更新所有的变化到 PCB 中（或从 PCB 到原理

图）。如果选择此选项，你还必须指出使用的方向，所以直接进入 ECO 对话框。 

•  执行菜单 Project » Show Differences 如果你需要选择控制的方向。如果你想比较其

他任何文件类型，那你就要使用这个选项，例如比较网络表和 PCB （也可以称为加载网络表

到 PCB）。 

6.1.2    解决同步过程中的错误 

大多数同步设计中出现的问题一般分为两类： 

1. 缺少器件封装.。由以下情况导致： 
 原理图中的器件缺少封装信息。 

 忘记添加需要的 PCB 库到当前的有效库列表中 

 原理图中的封装没有匹配的 PCB 库元件 

2. 封装引脚编号和原理图引脚编号没有匹配。Altium Designer 支持用户自定义引脚到

焊盘的映射，映射默认要求是相同的编号/字母。在 PCB 模型对话框中定义引脚到焊盘的

映射关系（编辑原理图器件模型，选择对话框区域中的模型封装，点击 Edit)。 

要解决问题，执行一次 Show Differences，然后在差异对话框中点击 Explore 

Differences 按钮。 这时将弹出差异面板，以及显示出问题的信息。这个面板显示出原理图与

PCB 中的问题对象。单击显示出其中的一个对象。 

注意: 如果有大量的网络连接关系更新，则可以很容易清除 PCB 编辑器中的网络，然后同

步过程将重新加载所有的数据。最后需要重新应用网络信息到所有布线，此过程的实现请执行

命令 Update Free Primitives from Component Pads (Design » Netlist)。 
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图 46 处理同步问题 

6.2 设计更新到 PCB 

如果你使用 Altium Designer 的 PCB 编辑器来做板级设计，则从原理图中更新设计信息到

PCB 中的最好方法是使用设计同步器。使用同步器，就不需要在原理图中创建网络表并导入到

PCB 中。执行 Design » Update PCB 将启动同步过程。 

当你有一个 PCB 文件并执行此命令，将弹出 Engineering Change Order 对话框。对话框

中显示出 PCB 必须与原理图匹配的变化信息。 

你同样可以使用 Project » Show Differences 命令来更新设计。使用设计同步器，可以更

全面的控制更新过程。 

6.2.1  使用网络表更新设计 

在大多数情况下，同步器已经取代网络表的加载。在一些情况下，原理图是在其他 EDA 软

件环境下绘制的，那这个时候网络表就可以用于 PCB 的设计中。 

使用差异比较引擎，网络表中的元件与连接关系信息可以被比较更新到 PCB 中。 

使用网络表直接同步的功能并不强大，因为直接同步原理图与 PCB 元件的过程是由一个独

特识别码（UID）来产生的。通过使用独特识别码，器件编号不需要同步链接，并可以双向更

新。 
6.2.1.1 加载网络表 

加载网络表： 

•  执行菜单命令 Project » Show Differences。显示出 Choose Documents to Compare

对话框。 

•  选中使能 Advanced 复选框。 
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图 47. 在 Choose Documents to Compare dialog 对话框中选择高级模式 

•  在窗口的一边选中需要的网络表，另一边选中 PCB。网络表文件必须在 Altium 

Designer 打开或者被包含在工程中。 

•  当单击 OK，确认对话框中将显示出无法使用独特识别码实现匹配。单击 Yes 继续使用

器件编号来匹配。 

•  差异窗口将弹出，过程和直接同步是一样的。 
 

6.2.2    练习– 更新设计 

在这个练习中，你将从原理图中更新设计数据到新建的 PCB 中。这意味着，所有需要的封

装必须在现有的器件库中。请考虑以下因素： 

•  封装在工程的 PCB 库中，并且是自动可用的 

•  对于从集成库中放置的器件，如 PIC 微处理器，默认的状态是从集成库中查找封装

的。因此器件库在设计更新的过程中必须是可用的。 

更新设计： 

1. 在库面板中，单击按钮打开 Available Libraries 对话框。该对话框列出当前所有可用

的器件库。 

2. 确定 Temperature Sensor.PcbLib 这个 PCB 库已经在 Projects 标签中列出。 

3. 在 Installed 标签中，确定以下的库文件已经被添加： 

  Microchip Microcontroller 8-Bit PIC16 2.IntLib 

  ON Semi Power Mgt Voltage Regulator.IntLib. 
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  Chip Resistor - 2 Contacts.PcbLib (对于 0805 封装，器件库路径为\Library\PCB sub-

folder) 

4. 两个默认的器件库也必须被添加，Miscellaneous Devices.IntLib 和 Miscellaneous 

Connectors.IntLib。如果这两个库未添加，则可以在以下文件路径中找到\Altium Designer 

6Altium Designer\Library。 

5. 在 PCB 编辑器下选择菜单 Design » Import Changes from Temperature 

Sensor.PrjPCB。弹出 ECO 对话框，对话框中显示出 PCB 必须与原理图匹配的变化信

息。请注意这时候并不需要打开原理图，因为这个过程是自动处理的。 

6. 向下滚动变化信息列表，信息中包含了添加 20 个器件、22 个网络、5 个器件类、1

个网络类，以及 3 个设计规则。按下 Validate Changes 检查变化的信息是有效的。 

7. 按下 Execute Changes 更新设计数据。关闭 ECO 对话框。 

8. 器件将被放置到新建的 PCB 板框的右边。 

9. 保存设计。 

注意: 确保如下项目和原理图文档存在。如果不存在，你可以复制以下的工程和原理图文

档到 Temperature Sensor 文件夹中，然后完成这个练习： 

- Temperature Sensor.PRJPCB 

- Temperature Sensor.SchDoc 

- MCU.SchDoc 

- Sensor.SchDoc 
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7.  PCB 设计对象                        (20 minutes) 

在 PCB 设计时可以用到很多种不同的对象, 大多数 PCB 对象是以铜箔或隔离区的形式出

现的. 这种应用对象不仅包括电气对象, 如导线和焊盘, 还包括非电气对象, 如文本和尺寸标注. 

因此, 设计时注意设计对象的线条宽度和对象所在的层是非常重要的. 

大多数 PCB 设计对象都可在 PCB 编辑器里编辑, 并被定义为 PCB 图元。 一个元件由多个

不同种类的图元对象组成, 这些对象只能在 PCB 库编辑器中编辑. 以下的课程将会进一步介绍

放置元件, 敷铜, 电源层分割和 Rooms 设置的具体操作方法. 

例如: 来看一个 PCB 设计对象的例子，如下图所示。 

 

图 48. PCB 的图元对象 

放置对象的命令可以通过 Place 菜单或者点击 Wiring 和 Utilities 工具条的按钮实现。 

 

要在放置时设置对象的属性可以按 TAB 键, 随即会显示该对象的属性编辑对话框. 

当对象被放置以后, 可以通过双击对象弹出属性编辑对话框. 或者单击选中对象, 在

Inspector 面板里编辑其属性。（F11 可以打开 Inspector 面板） 

要设置对象的默认属性可以在 Tools〉〉Preferences 的 Defaults 标签里设置。 

对象被放置的板层是由 PCB 的当前层所决定。 
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图 49. 导线放置模式 

7.1 PCB 基本设计对象 

7.1.1   导线 

Interactive Routing 命令用来绘制导线，同时会在导线上标注网络名。选择工具栏的 按

钮或菜单命令 Place » Interactive Routing (PT)可以开始画导线。点击已确定导线的起始端，

然后就可以开始布线，同时可选择不同的布线模式。 

在布线的同时按 TAB 键会弹出交互式布线对话框，你可以设置诸如线宽，尺寸和相关的规

则等参数。 

可以通过键盘的*快捷键切换布线层，同时会自动添加一个过孔。 

 导线放置模式 

开始交互式布线后, 当放置完第一段导线后

按 SHIFT +SPACEBAR可以改变布线模式。每

种模式定义一种布线弯折形状。 

有 5 种不同的弯折模式： 
任意角度 

45 度 

45 度弧.  

90 度直角 

90 度弧。水平和垂直。 

注意：在拐角风格的规则设置中可定义

圆弧的形状。如果规则中设置了尺寸调节规

则，就能在布线的同时通过按“，”键减小

拐角弧度，按“。”增大拐角弧度。 

 开始和完成模式 

导线放置模式另外还分为起始模式和终止模式，如图 49 所示。当你选择了导线放置模式

后，按空格可以在起始模式和终止模式之间切换。 

如果从一个已布好的网络上开始布线，新的布线回被附上同样的网络名。交互式布线将应

用那个网络的规则进行检测。 

CTRL+Click 某个已步完的网络可以加亮这个网络，SHIFT+CTRL+CLICK可以同时加亮显示

多个网络。 

1.  编辑导线 

当选中导线后会出现 3 段可调区，一个是导线的两端，另一个是中间，下面将介绍如何调整该

导线的方法。 

1. 调整导线端点 

 把鼠标移至导线的一端， 
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 按住鼠标左键不放 

 移动鼠标到达新的位置 

2. 在线段中插入顶点 

     鼠标放在导线中间 

     按住鼠标左键不放。 

     移动鼠标，顶点将跟随鼠标一起移动。 

3. 拖动线段 

 点击线段的任何一端 

 拖动至一个新的位置 

7.1.2 线条 

放置线条的命令可以在 PCB 上放置不同于导线的线条，比如：在非电气层绘制板的外形或

禁止布线层的外形。 绘制线条的操作与交互式布线非常类似，然而，这种线条不具备网络电气

特性。绘制在非电气层的线条不受设计规则的约束。 

画线的时候点击 TAB 会弹出线条属性对话框。你也可以通过双击线条来打开该对话框。 

选择工具栏 或 Place » Line 菜单命令可以画线条。 

7.1.3  焊盘 

使用菜单命令 Place » Pad 或 Place Pad 工具栏的 按钮可以放置焊盘. 

焊盘通常作为元器件的一个部分, 但有时也可以作为独立的个体, 比如测试点或定位孔。 
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图 50.焊盘属性对话框 

在放置焊盘的时候按 TAB 键或是双击已放置好的焊盘后会弹出焊盘属性对话框, 在对话框

里可以设置焊盘的属性。. 

如果焊盘在中间层或是底层有不同的尺寸, 必须在尺寸和形状框中设置顶层到底层的焊盘

尺寸. 点击 Full Stack 和 Edit Full Pad Layer Definition 可以定义更多更复杂的焊盘形状. 

可以给焊盘分配网络, 定义焊盘的电气特性(终端, 路径或发射端)或设置焊盘孔是否度锡. 

NC 钻孔软件也可以独立设置焊盘孔是否要度锡. 

焊盘可以设置为顶层或底层的测试点。 
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7.1.4 过孔 

使用菜单命令 Place » Via 或 Place Via 工具栏的 按钮可以放置过孔. 如果是自动布线

则会自动放置过孔. 

在放置过孔的时候按 TAB 键或是双击已放置好的过孔后会弹出过孔属性对话框, 在对话框

里可以设置过孔的属性. 包括过孔直径, 孔径, 网络名和起始终止层。 

 

　图 51. 过孔属性对话框 

在多层布线中, 如果在中间层布线, 设定了起始和终止层后会自动在换层处添加盲孔或盲埋

孔. 在通孔处会用 2 种颜色和标识明确指示该盲孔或盲埋孔的连通层.. 

过孔也能设置为顶层或底层的测试点. 

如果一个手动布线的网络要连接到内部电源平面, 可以按”/”键将过孔放置到适当的电源层. 

这一功能适用于处任意角度布线模式之外的所有布线模式。 
1. 阻焊层扩展（Solder Mask Expansions） 

选择 Specify expansions value 选项, 在填入适当值可设定阻焊层的膨胀数值, 该数值不

受设计规则的约束. 

2. 隆起（Tenting） 

选择隆起对话框会取消在过孔周围的助焊层隆起同时忽略规则的设置。 

7.1.5 字符串 

字符串是一组文本, 可以通过 Place » String 或 Place String 工具栏的来放置 图标放

置。 

在放置字符串的时候按 TAB 键或是双击已放置好的字符串后会弹出字符串属性对话框，实

际显示的字符在 Text 框中输入。 
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7.1.6图 52.字符串属性对话框 

7.1.6 特殊字符串 

为了辅助生产制造文档，Altium Designer 提供了特殊字符串输入。 这些字符串包含字

符，如：.Arc_Count 和.Component _Count， 这些字符串可以在 PCB 打印时显示对象的数

值。另一些特殊字符串则与层名，文件名和打印选项相关。.Comment 和.Designator 通常用在

创建元件封装的时候。 .Legend 字符串当放到钻孔导向层（Drill Guide layer）时，会显示钻孔

符号图标。 

大多数像 Layer_Name, .Pcb_File_Name 和 .Pcb_File_Name_No_Path 这些符号只有在打

印时被转换成对应数值。如果要在编辑时看到已转换过来的数值需选择 Tools » Preferences

菜单下的 Convert Special Strings 复选框。如：字符串 如果放在 PCB 顶层则会在

屏幕上显示  。 

使用 Place » String 菜单命令，在弹出的字符属性编辑框内的 Text 下拉列表框里显示了系

统可用的特殊字符串变量。（如图 53）。选择希望定义的字符串，放置即可。 
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图 53. 特殊字符串 

7.1.7   圆弧 

下表列出了画圆弧的方式: 

菜单命令 放置工具栏 

弧(固定圆弧一端)  
弧(固定中心)  
弧(任意角度)  
整圆  

表 7. 圆弧绘制命令 

 所有命令都是用来画圆弧的  

 圆弧能放置在任意层上. 

 在绘制圆弧时按 TAB 键或双击圆弧后会弹出属性设置对话框, 在该对话框里可以设

置圆弧属性. 

 

图 54.圆弧属性对话框 
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7.2      多边形区域以及尺寸标注 

7.2.1   填充 

填充物是一块实心的矩形, 可以放置在任何层上. 可以通过 Place » Fill 或 Place Fill 工具

栏的 放置填充。 

放置填充的方法是先点击定义填充的一角, 然后移动鼠标设置对角。 在绘制填充时按 TAB

键或双击填充后会弹出属性设置对话框, 在该对话框里可以设置填充属性。 

选中填充后在其周围会出现调整手柄，可以通过选中手柄同时拖动的方式来调整填充的大

小。转动小圆圈可以调整填充的角度旋转角度。 

 

图 55. 填充对话框 

7.2.2    实心区 

铜箔区是一个多边形的实心对象。 虽然他是铜箔块， 但可以放置在任意的层上， 包括机

械层， 掩模层， 或丝印层。 

可以通过菜单命令 Place » Solid Region 或 Place Solid Region 工具栏的 按键来放置

实心区。 

要放置实心区需要定义多边形的每个顶点， 当绘制完后点击鼠标右键退出顶点设置模式。

在绘制实心区时按 TAB 键或双击实心区后会弹出属性设置对话框， 在该对话框里可以设置实

心区属性。 

实心区可以用来创建实心敷铜, 但不能创建网格型敷铜。 
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图 56. 多边形填充设置对话框 

在 Solid region 的页面设置上，可以看到一个选项 Polygon cutout，这个功能可以放置板

形剪切块。如果勾上该选项，可以在相应区域显示板形剪切。板形剪切同样支持生产加工 。另

外板形剪切的行径轨迹可以输出到 Gerbe 和 ODB++，也支持 3D 显示并能输出到 3D 打印和智

能 PDF。如图 57 所示，就是板形剪切块 Cutout 的实例。 

 
图 57  板形剪切块 

7.2.3    尺寸和坐标 

尺寸和坐标可以放置到 PCB 的工作层上。 所有显示的测量值和光标位置都与当前原点有

关. PCB 的绝对原点(0, 0)在工作区的最左下方。  

你能通过菜单命令 Edit » Origin » Set 在 PCB 工作区的任意点设置当前原点。 选择 Edit 

» Origin » Reset.菜单命令可以复位绝对零点。 



Module 3: Schematic Editor Basics 0 - 64 

 放置尺寸标注 

尺寸标注能被放置在当前工作层上， 选择 Utilities(View » Toolbars » Utilities)工具条放

置 Dimension 标注图标或 Place » Dimension(PD)子菜单命令。 用鼠标点击来确定标注的起

点和终点。 在标注时注意状态栏的变化。按 TAB 键设置标注的属性， 如： 字体的高度和宽

度。 右键点击鼠标或 ESC 键可以完成标注。 
调整标注的起点和终点时， 标注的尺寸会自动更新。 

 放置坐标 

坐标 X,Y 所指示的信息是所标注位置和当前原点的

相对距离。 X 值表示与原点的水平距离， Y 值表示与原

点的垂直距离。点击 Place Coordinate 工具栏的 或

Place » Coordinate(PO)菜单命令即可放置。 右键或

ESC 可以退出放置坐标。坐标的数值会随着放置位置的

移动而变化。 

 封闭对象 

导线，填充和圆弧等可以用于在特定的电气层上定义一个区域，这个区域做为布线时的壁

垒。即不可在 keepout 外进行布线。被定义了 keepouts 的对象在输出操作时将被忽略，如出

图和打印。 

菜单命令 Place » Keepout 或快捷键(PK)能定义封闭边界，已经放置好的导线，填充和圆

弧能通过设置 对象属性对话框里的 keepout 选项定义为特定层的封闭边界。 

 粘贴命令 

PCB 编辑器里有另一个粘贴命令—Edit » Paste Special。这个命令可以一次粘贴多个已拷

贝的对象。 

在使用该命令先选择 Edit » Copy (EC) 或 Edit » Cut 将选择的对象拷贝到剪贴板，.然后点

击选择粘贴参考点，该参考点就是今后复制对象时的鼠标定位点。 

在 Paste Special 对话框中可以选择 paste objects on the current layer 选项将粘贴对象复

制到当前层。选择 Keep Net Name 选项保持原先对象的网络名。如果不选中，被粘贴对象的

网络名为‘No net’。 

 

图 58. 特殊粘贴对话框 
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如果是拷贝元件，Duplicate Designator 选项将变成可选，如果不选中，所粘贴的元件将

按顺序递增，如果选中，复制的元件序号将相同。 

选择 Add to Component Class 选项决定了所粘贴的对象是否属于同一元件类。 

7.2.4    PCB 设计规则对象的练习 

1. 打开 Objects.PcbDoc.  

2. 放置一些焊盘然后用导线连接起来, 尽量使用多种布线模式. 

3. 选择每个对象并观察他们的可调手柄. 

4. 双击对象在弹出单属性编辑框里重新定义新的值, 观察对象的变化. 

5. 关闭 PCB, 不要保存. 
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-图 59.用 PCB 面板选择器件 

8.    PCB 查询，全局编辑以及设计复用 （15 
minutes） 

8.1     PCB 查询，全局编辑 

　作为一个设计人员,面临的最大的挑战之一是，管理在设计过程中产生的大量的数据。为

了完善这些，Autium Designer 提供了一个强大的数据编辑系统。该系统可以采用多种途径来

管理，查询和编辑设计数据。 

软件提供了灵活的方法编辑数据，三个方式可以用来访问和修改设计对象： 

 传统的图形视图 

 Inspector 面板(按 F11 来切换) 

 List 面板(按 F12 来切换) 

Inspector 显示的是目前选定的对象属性，选定对象的总数在其底部。要注意的是，

Inspector 可以同时编辑不同类型的对象。 

List 面板给出了在原理图和 PCB 工作组中的电子数据表样，或对象的列表。在此面板中

可以编辑单个或多个单元。 

强大的过滤引擎管理着当前编辑的数据总量。获得

过滤数据可以用 Find Similar Objects 对话框，PCB 编

辑器面板，或在过滤器面板中输入查询语句。 

Filter 过滤面板是用来键入查询，过滤整个数据

集，并且 List 面板只显示那些满足查询条件的对象。那

些没有显示高亮的对象已经过滤掉（而不再可编辑） 。 

一个强大的数据编辑系统可以同时进行对多个对象

的编辑。 

利用数据编辑系统的基本方法是： 

 Select：选择所需编辑的物体 

 Inspect：查看对象属性  

 Edit ： 编辑对象的属性 

8.1.1   查找并选择对象 

2.    用 PCB 面板 

PCB 面板可以浏览 PCB 上的对象。 
• 面板上方的选项控制如何高亮被选择的对象。 

- Mask:这个选项将会把我们感兴趣的对象之
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外的，其他所有的对象暗淡下去。此时他们依然是可见的,但是不能被编辑。用软

件底部右边的  来控制高亮对象与其他对象的对比度。 

- Select: 选择目标对象。选择的对象采用不同的白场色调技术进行高亮。 

- Zoom: 缩放以显示高亮对象。 

- Clear existing:自动清除先前存在的高亮对象. 

• 使用 CTRL +点击相结合，可高亮多个对象。 

• 右键点击面板，来控制按哪些类别显示。这是一种非常快捷的排列对象类型方法。 

• 点击 Clear 按钮 清除所有的高亮和选择动作。 

• 高亮结果显示在三个视图中—图形,列表 List 和 Inspector 面板中。  

 

-图 60 用 PCB 面板高亮显示两个网络 

3.    使用 Find Similar Objects 
对话框 

当工作中遇到具有相同属性的一组对

象，例如元件和网络，用这个面板是一个很

好的方法。在工作中批量修改对象的属性，

利用 Find Similar Objects 对话框能很有效。 

 启用 Find Similar Objects 对话

框： 右键点击一个关心的对象,

然后从弹出菜单中选择 Find 

Similar Objects…。 

 右图所示对话框将出现列出了被

选对象的属性。几乎每个属性都

有一个下拉菜单。如果你想用其

图 61 用 Find Similar Objects 对话框高亮所有

元件注释
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中之一作为匹配标准,那么在这里可以进行设置。 

 点击 Apply 将会运行查找匹配的对象，击 OK 将会关闭该对话框，并运行搜索. 

 这个将选择所有跟查找标准相匹配的对象。图 61 用 Find Similar Objects 对话框高亮

所有元件注释 

 61 显示了 Find Similar Objects 对话框配置查找并选择所有 PCB 元件标识的字符

串.  

 激活 Run Inspector 复选框可以自动启动 Inspector, 在 Inspector 可以编辑选中的

元件的属性。 

4.2.    使用 Filter 面板 

同样可以通过一些描述对象的查询语句直接访问这个强大的数据过滤引擎。 

 按 F12 启动 Filter 面板，在这个面板中写入查询语句。 

 一条查询语句就是一个指令，在输入的时候要用语法关键字。例如，在 PCB editor 

List 面板中输入查询语句 IsComment or IsDesignator 将会缩小显示的内容

的范围。在 PCB 中只显示元件标识和元件注释。 

 点击 Helper 按钮，就会显示出一个完整的查询语句关键字列表。在 Query Helper

对话框中当鼠标放在一个关键字上，按 F1 键就会显示该关键字的描述。 

 参考文档， An Insiders Guide to the Query Language article.pdf 是一份针对逐条

查询语言信息的权威指南。 

•  

-图 62. 用 Filter 面板查询设计数据并访问特殊对象 

5.3.       使用 List 面板 
List 面板同样可被用为查找并编辑对象属性。当你想检查/比较属性或只编辑某些对象时，可以

使用 List 面板。 

• 按 Shift+F12 来开启或关闭 List 面板. 

• 在列表中单独的一个对象也可以被编辑,按空格键或右键点击选择 Edit.  

• 多个对象也可以被同时编辑。先选中，按空格键，填入新值，按回车确定。 

• 数据可以从电子数据表格中粘贴过来,也可以把数据粘贴到电子表格中去. 

• 同一类的元件，还可以把它们的组成部分显示出来。 
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-图 65.剪切板 

• 可以从 List 列表右键点击弹出菜单中选择 Remove Non-Selected 保留选择的器件。 

 

图 63. 用列表查找编辑所有属性和注释 

8.1.2    查找编辑所选元件 
 Inspector 面板用于检查并编辑当前选中元件

的属性。当你编辑所有选中的元件时可以用

Inspector。 

• 按 F11 启动或关闭 Inspector 面板. 

• Inspector 可以被用于检查一个或多个对

象. 

• 所选元件可以采用多种方法设置。包括

写查询语句，手动输入或用 Find Similar 
Object…对话框。 

• 不同的对象通过可用的相同的属性被选

中并编辑。 

• 在 Inspector 中修改参数值后按回车应用

到设计中去。 

• 在 Inspector 中可以替换字符串。 

8.2 设计复用 

8.2.1    粘贴板（Clipboard panel） 

粘贴板提供了一种存储设计为后续重新使用的

方式。该面板可以存储原理图、PCB 板、和代码数

据。粘贴板和片段面板相比唯一的不足是保存的数

据不像后者可以始终保存。 

粘贴板另外一个优势在于可以从 windows 粘贴

板中读取数据，使得数据可以从其他程序转移到

Altium Designer 内。这个功能开启是在 

-图 64. Inspector 显示所选器件的属性 



Module 3: Schematic Editor Basics 0 - 70 

DXP » Preferences » Systems » General.  打开

Monitor clipboard content within this application 

only 选项。 

8.2.2   片段面板 

片段面板提供一种方法，能够将设计的一部分被其

他的设计所利用。.这个面板存储原理图，PCB 和程序

代码的片段。  

 点击 View »  Workspace »  System »  

Snippets 来打开片段面板。 

 内容分成几个文件夹存放。它们就是普通

的 Windows 文件夹，可以点击“Snippets 

Folders…”来设置路径。 可以设定多级文

件目录，使用网络共享文件夹可以方便的

把片段和整个设计团队分享。 

 选中 PCB、原理图或者源代码的某些部

分，然后从右键单击，从弹出菜单选择

Snippets »  Create Snippet from 

selection，给摘录的片段填写好名字和注释，指定好存储路径，最后保存。 

 点击选中片段面板里的片段，然后再点

击 Place 按钮，将片段放置到设计文件

中。 

 在建立片段前最好是复位器件的设计标

号，防止在以后使用时，设计中碰到同

样标号的器件，引起错误。 

8.2.3    收藏夹 

像网络浏览器一样，Altium Designer 提供收藏

夹功能，保存收藏的文件以备以后使用，以预览方

式保存在收藏夹里。 

收藏夹很方便的把和项目相关的资源关联在一

起。项目收藏的文件存放在和项目相同的路径，名

字是 ViewOf 的文件夹内。 
• 点击打 View » Workspace panels »  

System »  Favorites 开收藏夹。 

• 内容分成几个文件夹存放。右键弹出菜单可

以新建文件夹。  

图 66 片段面板 

 

 
图 67.收藏夹面板 
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• 右键单击弹出菜单可以选择 Add Current Document View 将当前打开的文件添加到收藏

夹。 

• 双击某个收藏文件查看源文件。                                                                 

• 收藏文件预览显示图片的大小可以在 Preferences》System》View 中设定。 

8.3 练习 － 全局编辑 

这个练习演示了不同的方法来改变器件布线和圆弧的宽度，还有器件文字的高度。 

8.3.1   改变器件注释的可见性 

1. 在 4 Port Serial Interface PCB 文件中找到 S1。  

2. 在器件 S1 的注释上单击右键，弹出菜单上选择 Find Similar Objects…。 

3. T 在 Find Similar objects 对话框中设定匹配条件。按照图设置匹配条件。 

 

4. 选中 Run Inspector 复选框，去掉 Create Expression 复选框 点击 OK 。 

 

5. 在 Inspector 内将 Hide 属性设置成 False，回车确定。 
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所有板上器件的注释都可见了。 

8.3.2    改变设计标号和器件注释的高度 

1. 在 PCB Filter 输入语句 “IsDesignator or IsComment”，点击 Apply。 

2. 在 PCB Inspector 内选中“Text Height”, 输入 40mil 后按回车确认变更。 

8.3.3   编辑中间层的布线和圆弧的宽度 

1. 打开 NBP8 Xilinx Virtex-II Pro BGA456 Rev1.01 示例项目, 从 

C:\Program Files\Altium Designer 6Altium Designer\Examples\Reference 

Designs\Daughter Boards\NBP8 Xilinx Virtex-II Pro BGA456 Rev1.01\ 目录下,然后打

开 PCB. 

2. 打开 PCB 面板选择 Nets 。 

3. 点击 All Nets，在下面列出了所有的网络。在所有网络列表上右键，弹出菜单选

择 Select All 。 

4. 在 Primitives 标签单击右键，弹出菜单上选择 Show Tracks and Show Arcs 。 

5. 点击 Layer 标签，按照各个层来排列。选中所有在 4 midlayers 的布线和圆弧。 

6. 打开 PCB List 面板。 设置成如下： 

. 

8.7. 点击 Clear 按钮 (SHIFT+C) 在软件的右下方移除掩盖和选中的对象.。 

注意:大量的查询语句都可以在 Filter 菜单边按 Y 弹出的例子 Examples 中找到。 
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9.  设计规则 （Design rules） （30 Minutes） 

9.1 设计规则浏览及添加设计规则 

在 Altium Designer 中， 设计规则通常用来定义用户的设计需求。 这些规则涵盖了设计的

方方面面， 从布线宽度， 对象的隔离间距，内电层的连接风格， 过孔风格等等。 设计规则不

仅能在 PCB 设计的过程中实时检测， 而且也能够在需要的时候进行统一的批量检测并生成错

误报告。 

Altium Designer 的设计规则不是 PCB 对象的属性， 而是独立的对象。 每条规则需针对具

体的 PCB 对象。 

设计规则可按优先级区分其应用范围。 例如： 有的约束可以针对整块 PCB 板， 有的则针

对某个网络集， 还有的则可约束另一个网络集。 合理的使用规则的优先级和作用范围， 就能

对 PCB 设计中的每个对象定义所需要的约束。 

这一部分将介绍如何定义设计规则和怎样做规则检查。 

9.1.1 设计规则的概念 

为了高效的应用设计规则， 设计人员必须理解规则的类型， 对象集， 查询语言和优先级

等概念。 

 规则类型 

有 2 中规则类型-一元型和二元型。 

一元型规则：这种规则只约束一个对象或一个对象集中的每个对象。如线宽约束。  

二元型规则：这类规则约束的是一个对象集的每个对象和另外一个对象集的每个对象之间

的电气关系。 因此，二元型规则有 2 个部分需要设置。 例如： 如果需要约束一组铜箔中的每

一块铜箔和另一组铜箔中的每块铜箔之间的间距就需要使用 2 组查询语句分别定义。 

 对象集 

它用来描述规则所约束的对象。 对象集的范围由规则查询语言决定。  

 

图 68. 规则中定义了约束的目标对象，它是”3V3”这个网络 
 

Figure68. The scope of the rule defines the objects it targets. This rule targets the 3V3 net. 



Module 3: Schematic Editor Basics 0 - 74 

9.1.2   添加设计规则 

设计规则在选择 Design » Rules 这个菜单命令后所弹出的 PCB Rules and Constraints 

Editor 对话框中定义。 

 

图 69 PCB 约束和编辑对话框 

设置设计规则步骤如下： 

1. 点击+展开该规则的子目录树。 

2. 同样, 在展开的目录树中点击+展开目录树, 此时显示了 4 个线宽的约束规则。 

3. 点击一个需要设置的规则, 随即在右侧显示该规则的属性。 

4. 右键点击一个规则大类可以添加该类的一个新规则。 

 你可以通过 PCB 面板来检索规则所定义的对象.。方法是将 PCB 面板的显示模

式设置为 Rules，然后选择列表的任意一个规则即可。 

 同时， 可以右击工作区的对象， 在弹出菜单中选择 Applicable Rules 即可导出

应用于该对象的规则。 

9.2 设计规则查询系

统及使用 

9.2.1  规则的查询语言 

查询语言是对规则应用对象

的描述。设计规则的约束对象可

以用直接输入查询语言， 或是在
 

图 70. 使用查询语言构造规则查询 
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语言编辑区左侧的控制区选择，抑或是查询语言构造器的方式来定义。 

9.2.2 查询语言错误 

如果你键入了一个错误的查询语句，当你试图关闭规则设置框时会弹出一个出错对话框。

及时修正这样的错误非常重要，否则做在线实时检测会非常慢。同时设置错误的规则会在左侧

的对话框里以树型方式显示，他们的名称是红色的。 

9.2.3   Query 用于改变铺铜之后过孔的连接方式 

使铺好铜的 PCB 板中的过孔联接不呈十字交叉状，而是直接联接，可以采用规则 rules 里

的 Query 做如下操作： 

1，1. 点击菜单 Design，在下拉菜单点击 Rules，找到 Plane－>Polygon connect 

style，右键点击选择 New rule。出现如图 71 所示。 

 
图 71 多边形连接类型 

2，2. 在新设置的 New rule 项设置过孔联接方式。“name”栏随便取个名字，在

“where the first object matches”栏选“advanced（query）”，在“full query”栏

键入“IsVia”，如图 72 所示。（该键入的信息的语法可以点击“Query Helper”来参

考，如图 73 所示）。意思是设置过孔的联接方式。 
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图 72 设置相应的 PCB 规则 

 
图 73Query 语言定义 

3，3. 在“Connect style”栏的下拉选项中选择“direct connect”。 
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4. 设置规则后，确定保存，然后推出，执行 Repour all polygons 重新铺铜。重新铺

铜后的效果如下图 74 所示。过孔为直接连接，其他 SMD 封装为热焊盘连接。 

 

图 74 做好规则设置后的铺铜效果 

9.3 设计规则优先级  

 

图 75 在规则设置后确认规则的优先级 

 选中其中的一个规则，然后点击 Increase Priority 或 Decrease Priority 按钮即可实现选中

对象的优先级别排列。排在最前面的优先级别最高。 
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10.   PCB 布局                          （45 Minutes） 

10.1   查找及移动器件   

10.1.1   查找元件并放置 

 如果能确定元件在板上放置的位置,那么点击该元件

并拖动到相应的位置. 

 否则,选择 Edit » Move » Component (M C)并点空

白区域,就会出现 Choose Component 对话框.. 

 在出现的元件列表中,选中将要放置的元件. 

 你也可以选择你喜欢的方式—把光标移动到元件上选

择元件。 

 找到元件封装的另外一个技巧是使用原理图作为参考.

在原理图中选中元件,然后选择菜单 Tools » Select 

PCB Components 。 

 你也可以在 Navigator 面板中选中元件同时按住

ALT 键,通过探针的方式从原理图指向 PCB.(注意,该

项目必须通过编译)。 

10.1.2    移动元件 

 点击并拖动来移动一个元件。当移动元件的时候，该元件上的所有飞线将随着一起

移动。同时其他飞线将消失。 

 当你移动元件的时候，飞线将会动态优化使具有同一网络名的飞线路径最短。 

 同时，当你移动元件的时候，点击 N 键，将不会显示相关飞线。 

 当移动元件时，点击 L 键，可以选择把元件放置在顶层还是底层。 

1. 元件组合 

组合功能是把元件做成一组，这样这个元件组在移动的时候，里面的元件可以一起移动，

也就是象一个单独的元件一样。 

• 可以定义多重组合。 

• 创建一个元件组合。选择好要组合的元件，然后在工具栏中选择元件放置工具中的

Create Union from selected components 图标。 

• 从组合中移除元件，或撤销这个组合，选择工具栏中的元件放置工具下的 Break 

Component from Union 图标，然后出现一个对话框，显示了在这个组合中的所有元

件的列表。在这里，选择元件从组合中移除。选择所有的元件移除这个组合。 

图 76  选择元件对话框 
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2. 元件放置栅格 

当放置或移动元件时，捕获元件放置栅格，这种栅格有 X 和 Y 的坐标值，在 Board Option

对话框中设置。 

10.2   交互式布局命令 

在 PCB 设计中有很多半自动工具可以让你编辑 PCB 设

计的布局。通过 Edit » Align 菜单，或 Tools » 

Component Placement 菜单，或工具栏中的 Alignment

工具来进行访问。下面章节描述了他们的使用方法。 

10.2.1  Alignment 命令 

Alignment 命令（Edit » Align）作用于选中对象。 

10.2.2  Spacing 命令 

用 Alignment 工具中的间距命令可以使被选中的元件水

平或垂直间距等距，增加或减小间距。.增加或减小所选元件

的水平(或垂直)间距意味着元器件参考点之间的水平（或垂直）距离增加或减少了所规定的

量，这个量在元器件 X（或 Y）位置网格中定义。 

10.2.3 Arrange 命令 

自动移动元件的命令如下： 

排列命令 Behavior 

Room 内排列 room 内的元件按照规则排列 

矩形框内排列 在定义好的矩形区域内排列元件 

板外排列 板外区域的元件重新排列 

10.2.4 移动到栅格 
所有没有被锁定的元件移动到与其最近的器件放置栅格点。 

10.2.410.2.5练习—放置元件 

在这个练习中，用下面的图做参考，确定温度传感器的位置。  

图 77 用 Align alignment 工具排列所选元
件. 
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图 78. 温度传感器电路板元件的一种放置方式 

1. 这块板的元件不一定要按照上面所示的样子来放置，这只是一种解决方案。 

2. 当你在按空格键旋转元件时，你将会注意到元件的标识依然定位在元件左上角的位置

上。这是元件属性对话框中的 Designator 栏内的 Autopostion 选项来控制。 手动确定

一个标识的位置，可以单击并拖动它到想要的位置。如果需要的话还可以按空格键旋转

该标识。 如果临时需要选中工作组内所有的标识，在 PCB List 面板中最上面的查询过

滤器中输入查询语句 IsDesignator。当完成操作后按快捷键 Shift+C 来清除本次筛选。 

3. 每个元件同样也可以拥有一个注释。你可以在属性对话框中控制显示注释.。为所有元

件的注释设置隐藏，在 Filter 面板中输入查询语句 IsComment (确认 Select 复选框被激

活并按下 Apply 按钮)， 然后按 F11 键来打开 Inspector 面板。 Inspector 面板可以被用

于编辑所有选中的注释字符， 确认隐藏状态复选框并按回车键确定。 

4. 一份设计文件被放在备份文件夹内。你可以用它作为参考.。 

5. 在进行布线设计之前保存该设计。   

 



Module 3: Schematic Editor Basics 0 - 81 

11.  PCB 布线（PCB routing）（60 minutes） 

11.1   交互式布线（Interactive routing）   

布线是在网络的节点与节点之间定义连接路径的过程。 

Altium Designer 包括强而有力的交互式布线功能，可以有效的帮助你进行电路板布线。有

两种交互式布线指令，两者都可通过 Place 菜单访问。 

 交互式布线（Interactive Routing ）–放置线段来进行选择的连接之间的布线。 预知功

能允许你预知当前线段的最佳路径。该模式同样支持回路自动移除，允许你重走已完成

的路线，新的路线会取代原有的路线。 

 差分对布线（Differential pair  Routing ）–该命令用于对差分对进行布线。 

 这个功能会自动完成布线，当你按住 Ctrl 键后再点选鼠标左键即可。 

当您选择一个布线指令并且开始布线时，可以按键盘上的 tilda (~)键，弹出与当前布线操作

相关的快捷建列表。 

11.1.1   管理飞线 Managing connectivity  

一旦元器件被放置到 PCB 文件中，依照你的原理图连接情况，飞线会显示哪个焊盘属于哪

个网络。 

 当你布线(在布线层用导线连接两个焊盘) ,两点间的飞线将不再显示。 另外，如果任何

飞线之间有更短的路径出现，那么将会显示更短的飞线。 

 在一个网络里的飞线的排列或者模式叫做拓扑。在一块电路板内的全部网络的默认拓

扑是最短的，这个是通过应用的布线拓扑设计规则来决定的。因为它是最短的， 当你

移元器件的时候，它的周围的飞线可能从一个焊盘跳转到另一个焊盘，以保证飞线尽

可能最短的长度。  

 你可以改变飞线的颜色，在 PCB 面板中的 NET NAME 上双击鼠标左键就会开启 NET

编辑对话框。  

11.1.2 交互式布线的线宽 Interactive Routing track width 

当你选择一种交互式布线指令并且开始布线， 你开始

的布线宽度是在参数对话框中的 PCB Editor – Interactive 

Routing 里设定的，配合设计规则里的线宽约束进行布线。 

当参数设定允许你在布线时改变宽度时， 它总会通过

应用的规则进行约束，如果你要改变的线宽的值超出了规则

定义的范围，它会自动固定于规则的最大值或最小值。 

线宽/过孔尺寸模式  

 User Choice –当这模式被启动，布线的宽度会

图 79.通过这些设置决定交互式布线操作 
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从我的最爱宽度的列表中选出来，按 Shift+W 会显示我的最爱列表。使用参数对话

框中的 Favorite Interactive Routing Widths 按钮来配置列表。 

 Rule Minimum –当规则最小值这个模式被使用时会套用设计规则的最小值 

 Rule Preferred –当规则最好值这个模式被使用时会套用设计规则的最好值 

 Rule Maximum –当规则最大值这个模式被使用时会套用设计规则的最大值 

提示： 在布线时按 3(对布线宽度来说) 或按 4(对过孔尺寸来说)快捷键时，你能切换上述四

种状态。 

11.1.3     Editing during Routing 布线时的编辑 

除了按 Shift+W 改变布线宽度之外，也可以编辑布线的其它设定。按 TAB 键，将会打开交

互式布线编辑对话框(如图 80) ,你可以编辑许多跟交互式布线有关的设定，包括编辑布线的宽度

和过孔的尺寸。   

 

图 80 交互式布线对话框 
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11.1.4 在交互式布线期间处理冲突 
当你在电路板上进行交互式布线时。 你可以控制 Altium Designer 如何处理潜在的布线冲

突情况。遇到冲突的解决模式的选项在参数对话框中的 PCB 编辑器 PCB Editor – 
Interactive Routing 页面来进行设置。如图 81 所示。  

 

图 81. 定义交互式布线遇到冲突时的处理模式 

化解冲突模式包括︰ 

 None –用这种冲突模式表示都不允许，你能在所有的物体上方布线，但有冲突会高

亮警示。 

 Push Conflicting Objects –推挤障碍的模式。如果你使用这种交互式布线模式，会用

现有的布线推出空间给新的路线 。  

 Walkaround Conflicting Object –环绕障碍模式。当使用这种环绕障碍的模式进行交互

式布线时，新的布线将环绕现有的障碍，或者有可能的话会跳过障碍，会出现预览

的新路线到目标。 

 Hug And Push Conflicting Object–环绕并推挤障碍的模式。这个模式是环绕功能和

推挤功能的结合。它将跟随你的鼠标并且环绕障碍，另外，当布线妨碍现有固定的

对象时，同时也会执行推挤功能。固定的对象一般的是焊盘，也有一些锁定的对

象，如导线和过孔。 

提示： 当你布线时，按 Shift+R 快捷键可以切换不同的模式，可以在状态列看到你现在的

模式 

11.1.5 另外的交互式布线选项 

Altium Designer 布线的能力已经被发展到使布线的过程很有效率。还有另一些选项也可提

高效率，这些可以在参数对话框中的 PCB Editor – Interactive Routing 页面(图 82)进行设定。   

 这些包括︰  

 Restrict to 90/45 –当你在交互式布线期间按

Shift+Spacebar 键时，共有 5 种布线的角度模式

循环切换。 使用这个选项可以限制成两种角

度，你只能在 90 度或者 45 度角度之间选择。 

 Auto Complete –如果你使能这个选项，在布线

时 按住 Ctrl 键，再在飞线上点击鼠标左键将

会自动完成该网络的布线。  

图 82.另一些交互式布线选项
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 Automatically Terminate Routing –当这个选项被勾选，你完成布线到目标焊盘时，会

自动释放，进而可以点选其它焊盘继续布线而不用点鼠标右键释放。 

 Automatically Remove Loops –当这个选项被勾选，产生回路的布线会被自动删除。 

 Hug existing traces(Workaroud mode) –使能这个选项时，布线试图跟随鼠标并找到

环绕障碍的路径，另外它包含环绕现有布线路径的功能。 

提示： 自动移除闭合回路是可以依照 NET 被关掉的，在 PCB 面板中点两下你的 net 即可

访问其网络属性来改变设置。 

11.1.6 预知性布线 Look-ahead routing 

PCB 编辑器的交互式布线模式合并预知性布线功能来进行布线。这个功能允许你迅速并且

准确在对下一线段进行布线。在你使用预知性布线功能来导线你的布线时， 当有障碍物时，你

将注意到布线端点不总是保持附在光标上，它黏着在你接近的一个现有障碍(当解决冲突模式选

择在遇到障碍时停止的选项) 。这个功能阻止你违反任何安全间距的约束。 

11.1.7  工作在电气栅格 Working with the Electrical Grid 

没胆你放置一个电气对象时，如布线时放置一段线段，电气栅格便被激活。会有一八边形

图案在那些光标上表示这电气格点功能正在使用中，会自动将鼠标吸附到对象中心点。这个功

能对不在栅格上的焊盘布线很有效。当您在交互式布线的时候按 CTRL 键即可关闭并禁止电气

格点的功能。  

11.1.8  修改布线－自动移除闭合回路或者拖线 Changing the routing - 
automatically remove loops, or drag tracks 

Altium Designer 有 2 种方法改变已经完成的布线︰使用

交互式布线命令，和拖曳布线。 

 Loop removal 这个功能是自动除去多余的布线让

你重新布线。使用删除回路功能你能轻易的重新

布线，而不管原来的线是如何走的，都会自动删

除 。包括多层或是有过孔的复杂路线也会被除

去。 

 Dragging tracks 你也能部分拖动布线并且保持在

45 度角。 首先点选要选择的线段是在特殊光标

指示的选取状态之下，然后再点击并且拖动。如

图 83 所示。或者，另一个方式不是在特殊光标

指示的选取状态之下，按住 CTRL 键拖曳线段也

可以。  

 Dragging Arcs 拖曳弧角，你也能拖曳弧角部分

并且保持他们之间的距离。 只要点选 ARC 并拖

图 83. 注意到特殊光标指示了

在拖动选择的线段是保留转角 
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曳就会调整弧角大小，到你想要的位置，如图 84 所示。 或者，使用 Ctrl+click 并拖

动的快捷键可以不需要预先选中。   
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图 84.注意到特别的光标，当拖弧角时，出现 ARC 移动 

11.1.9  练习--交互式布线 Exercise – Interactive Routing 

在这个练习过程中，将对 LCD 模块以及 PIC(U1)微处理器之间的连接进行布线。 

1. 执行 Place » Interactive Routing，针对在右边的 LCD1 开始布线，依照预拉线布线

LCD1 PAD 到另一个 U1 的 PAD 的线段 

2. 试着走一条电源网络 

3. 试着使用聪明的交互式布线命令连接一些布线。  你应该是是各种各样不同的选项或点

或按，去使用它们 

4. 如果你布线走的很顺利，去走电路板上其余的网络 
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Figure85. The placed board, ready to route.放置好零件的电路板，准备布线。 

 

Tips for routing 布线的小提示 

• 它能帮助你把重要的网络预拉线改变颜色。要做这个就要在 PCB 面板内双击网络名称 

• 你也可以快速控制预拉线是否显示，只要使用 N 键即可 

• 使用 L 键会跳出层面及颜色设定，可以调整颜色以及层面是否显示 

• ＊号键可以切换到下一个布线层 

• 按 CTRL+G 快捷键显示并且编辑现在所使用的格点。  5 mils 较适合现在的工作 

• 以一个 2 层电路板来说有一层为水平面布线，另一层为垂直面布线是比较好的 

• 按空格键可以切换在 45 度角的时候布线起止模式 

• 按 shift+spacebar 键可以切换转角模式 

• 按 CTRL+CLICK。当你点击到网络时会高亮可以调整 Mask Level 指令调整淡化效果 

• 在布线时按 shift+r 快捷模式键切换违反冲突模式 

11.1.10   Pin and part Swapping 管脚和分部交换 

Pin/part swapping 被启用/不启用指那些已经摆放在 PCB 上的零件 

你可以选任何零件在 PCB Inspector 面板里(选一个零件然后点选 F11 就会跳出对话框

(FigureFigure86) 。 

pin/part swapping 被使能后，使用 Tools » Pin/Part Swapping 

命令子菜单来执行 PIN 跟 Part 的交换  

过程基本上对管脚和分部交换是一样的，在选择命令之后，一切在 PCB 工作区内被屏蔽(消失) ,

除了 swappable 的那些管脚之外。 

 

状态线将提示您下一个动作，要选择一个子网络(为一个管脚交换)  或者附属分部(为一个分部

交换) . 
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在点击一个管脚之后，你将被提示选择目标网络或者所包含的分部交换用。  Figure87，Figure88 

和 Figure89 为一个排阻(四组电阻)， 一管脚交换电阻器其它管脚的目标，适合一部分分部交换

其它 3 组电阻。 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure86.使管脚和部分交换成为可能的选择

 

Figure87. 可交换管脚被高亮 
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Figure88. 在一个管脚交换时，点击第一个管脚之后，可能的目标管脚被高亮   

 

Figure89. 在一个部分交换时，在点击部分内一个管脚，可能目标部分被高亮   

                                                                                               

11.1.11   Differential Pair Interactive Routing 差分对交互式布线 

差分信号正迅速地成为被更优先使用的方法，用在需要网络快速传递的电子产品内。 

要达到在 PCB 上交互式差分对的布线，Altium Designer 有很好的支持差分信号在线路图上进，

而在 PCB 上的差分对布线是同时布线。   差分对布线要从 Place » Differential Pair Routing 菜单。

你将被导引在选择一对信号，点击两者中任何一个开始布线。 
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Figure90. 被安排的差分对，注意到在对里的两个连接同时布线。 

 

提示： 更多关于的 Altium Designer 的差分对布线功能的讯息，参考应用注释，交互式和差分

对布线 

11.1.12   Multi trace routing 多重布线 

有使用多重布线的两种方式。  第一个方法是使用聪明的修线功能。 

这允许群组布线一起被选择然后一起延长。  你能使用连续的修线继续增加新线段 
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Figure91.聪明的修线工具能用来延长在上面看见的布线。 

聪明的修线工具是一件基本的工具因为它只着手在现有的 BUS 布线。  BUS 布线可以被使用多

重布线工具更容易操作这命令在 Place » Multiple Traces，使用这命令，你能从一个未布线零件开

始并且有效地从被选择的零件 PAD 中拖出布线，多重布线会自动聚集，如 Figure92 中所示。  

完全作为移动各种各样的多重布线群组选择的地方移动光标。 

  

 

Figure92.多重布线自动聚集  完全作为移动各种各样的多重布线群组选择的地方移动光标。 

当与多重布线命令合作时，记住以下讯息︰ 

• 按住 Ctrl 键，不是一个接一个零件 PAD 点，可以用框选的 

按住 Ctrl 只把选择限制在 PAD 物体，而不是选择本身的零件，这也作用在与这条选择被线

碰到(Select Touching Line)或是被矩形碰到(Select Touching Rectangle)的指令来选对象时。 
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• 按 TAB 键打开 BUS 布线对话，你可以设定 BUS 间距 

 

Figure93.设定 BUS 布线间距 

• 或者，使用，(逗号)跟。(句号) 快捷模式增减总线之间的间距。 

• 按 \ (反斜线)  改变末端调整(第 1 部分已经被放置) .  

• 按 ~ (Tilda) 会出现快速键列表  

 

11.1.13   Interactive Length Tuning 交互式长度调整 

在高速布线数字系统内等长布线是维持数据正确性的一个标准技术，而且是差分对布线不可或

缺的角色 

交互式长度调整允许改变弧度根据可用空间，插入允许调整及优化，和控制网络长度的动态的

方法，并且会依照规则避开障碍物。从 Tools » Interactive Length Tuning 启动，依照基本的设计

规则调整你的信号线，或者输入数值到对话框。 
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Figure94. 按 TAB 键(或者为快捷模式键按 Shift+F1)  你布线将停止，你能依照你的需要做改变值，等长布线
对话框。 

一旦启动，点击信号在线并且沿着网络移动鼠标增加振幅部分。  这交互式长度振幅光标指南

你在这振幅过程  

黄的光标指示可能的最小和最大长度。  绿色表明目标长度，当根据决定时适用匹配长度和最

大长度如 Figure94 中所示设计规则或者背景。这滑动指针显示怎样关闭你朝如 Figure95 中所示

取得适合的。 

 

Figure95. 动态使用计量器展示当前长度和有效的长度范围 

交互式长度调整的功能特色包括︰ 

目标长度可以被直接指定或者根据规则在你的设计过程中，一条网络线，或者手动设定 

有 3 种调整状态：使用线斜接，圆弧的斜接，圆弧走线。   

当使用线斜接 和圆弧的斜接 风格被使用时，要确切地定义振幅跟横距的目标长度来实现选择

的瞄准长度。  
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交互式布线的工具与其它 Altium Designer 的界面一致性保证了用户直觉和快捷键使用熟悉的键

盘快捷模式 

 

11.1.14   Finding and Setting Test Points 找寻和设定测试点 

 

执行 Tools » Find and Set Test Points 找寻在设计中 PAD 和 Via，按照测试点规则来执行操作。 那

测试点属性遵循适合这些 PAD 和 Vias 中的设计规则。 每个设定状态设计规则根据你的电路板

要求而定。 

 

Figure96.设计规则用来确定这类型 PAD/Via 用于测试点 和要将他们放于上的那些网络在线 

在启动命令之后，电路版被设计规则的 PAD 和 VIA 扫描。 

对话出现讯息,存在可能多少适合放测试点( 即 多少 PAD 和 VIA 已经被找寻那符合规则标准)  

并且在进行之前进行确认 ，下一个动作，第 2 对话框报告测试点的详细数目。 

提示： 当布线时，autorouter 不再自动安置测试点。  这是现在必须手动设置，然后通过设计规

则执行。 

 

提示： Altium Designer 现在有能力在线路图内将测试点处理和状态指令放于网络上或者总线

上。  这些指令然后能同步到放置的 PCB 和测试点上。首先放从用在线路图的编辑里指令的

PCB。选择 Place » Directive » PCB Layout.   

一旦摆放到网络在线或者是总线上，然后编辑那些指令在以前使用 Tab ,或者使用选中适合规

则放置时进行双击。 然后你能象往常一样增加规则。  在那之后你能增加一种测试点模式，为

增加测试点用法，但是这次选择测试点模式 。 

一旦全部网络和总线已经准备好要求的测试点使用方法及模式， 我们然后需要同步 PCB 的这

些变化。 执行 Design » update PCB 和全部指令将被导入到 PCB，设计规则已经为你产生。 



Module 3: Schematic Editor Basics 0 - 95 

一旦在 PCB 里你能从菜单工具运行 Tools » Find and Set Testpoints，  找寻并且确定

Testpoints。  这个功能在一张规定的网上为 testpoint 确定追最优点。  如果它不能找到一个

合适点，没有 testpoint 将被放置 

Clearing Testpoints 清除 Testpoints 

这命令 Tools » Clear all Test Points 清理现有设计的全部测试点。 

在启动命令之后，一次确认对话提示你清理全部测试点。  在从设计清理全部测试点之后，第 2

次对话空将显示所清理测试点的数量。 

 

11.1.15   Teardrops 

这命令用来增加泪滴对所选择的 PAD 和/或 VIA。 

补泪滴是在电路板增提防钻孔脱落的一种共同技术 

启动这个命令后，泪滴的选项对话框如 Figure97 中所示 ，允许你从全部 PAD 和/或 VIA 增加/删

除泪滴/。 

 

 

Figure97. 补泪滴对话框 

选择 Selected Objects Only 选项选择哪些 PAD/ VIA 要补泪滴。  补泪滴有 ARC 跟 LINE 两种模式 

使用强制补泪滴选项补泪滴会导致 DRC 检查失效。 

依照所选的建立报表，一份报告(DesignName.REP)  将被建立。 

这报告将被存在与 PCB 输出文件相同的文件夹路径里并且会自动开启。 

那些报告显示 PAD 和/或 VIA 被使用，多少泪滴生成， 多少泪滴失败的标识位置讯息。 

提示： 零件内的 PAD 和 free pad 都将被补泪滴。 报表将会被加到项目面板是一个 f ree 
document，会存到 Text Files 文件文件夹路径底下。  

 

提示：当多边形补泪滴是弧角式泪滴时，部分靠近滴泪的当多边会脱落。这是多边形的算法

引起的一个问题。  
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那些算法首分别先产生那些 PAD/VIA 和那些泪滴弧角外型，然后整理这些弧角形成一个连续

的轮廓，有时会失败在于这些弧角轮廓彼此交错，因此会互相抵消，所以泪滴旁的多边形就

脱落。解决方式就是使用线段式的补泪滴方式 
 
11.2（Automatic routing introduction） 自动布线介绍 

Situs 这套自动布线是用 topological 的方式自动布线，也就是利用 topological 去找电路版上计

算布线路径 

自动布线支持所有的电气特性并且依照设计规则布线，除了圆角的设计规则之外。  在这套软

件中还可以走差分对自动布线。 

11.2.1   Autorouting tips 自动布线提示 
 

• 这 PCB 电路板必须在 Keep Out layer 划一个封闭区域 

• 设计规则必须被正确地为要能定义布线的路线，才能正确布线，才会导致设计规则被破坏

的路线不能连接。 

• Situs 布线对话框里，使用设定报告来检查规则是否正确。 

• 布线层的方向必须设定。有预设的方向，但是这些是没有考虑所有层面的，因此建议手动

因为这是必须要检查的。布线层面跟布线方向是一定要先设定的。在 Edit Layer 
Directions 中设置布线方向。 

• 你能保护已经走好的线或是扇出或是全部的布线，只要你勾选 Lock all Pre-routes 选项，

在 Situs Routing Strategies 对话框(Auto Route » Setup)，也可以在扇出以及连接少数部

分的线时使用 

• 对象的网络名称没被锁定就表示再自动走现实可以被移动或搬动 

• 在信号层禁制区内放置对象会封锁所有层面禁止进入 

• 布线层禁制区对象产生区块在布线层，布线会避开。 

• 布线并不会在非电气层布线 

• 在很小的角度连线时布线器很敏感，要注意对齐器件。 
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11.2.2    Running the Autorouter  

 执行自动布线 
Autorouter 需要最小设定。去执行那些布线的对策，选择 Auto Route » All  显示 Situs 布线对

话框。简单的点到对策设定就可以使用了

 

  

 

 

 

 

 

Figure98. 自動佈線對策對話框 
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11.2.3   Creating a Custom Routing Strategy 建立一个自订布线对策 
你不能修改预设对策，因此建立一个自订布线对策，从菜单选择 Auto Route » Setup。建立

一个自订对策最简单的方法是复制一个已经存在的，例如，预设两层板的策略。 

就像我们定义布线规则，确定各种布线过孔，你可以确定布线策略，选择对角线或直角线。  
如果你在 Situs Strategy Editor 编辑器内的选择 orthogonal，你需要增加 Recorner 传给这个对

策。你可以容易的设定布线策略内容，你可以控制过孔数量以及布线限制角度以及转角设定，

你可以把策略选项拉到右边编辑这个新的策略。 

 

 
Figure99.自订制布线对策使用更便宜的过孔和直角的布线 

11.2.4    Exercise – Autorouting 练习自动布线 
1. 点选 Autoroute 菜单里面的 ALL。选择预设 2 层板对策，如果你想保持你已走的线，勾选

击 Lock All Pre-routes 选项，并且点开始自动布线 

4.2. 检查布线的结果。  为了更容易检查每个层面，按 shift+S 快捷键去切换成单层显示模式， 
然后按 *号键切换顶层跟底层。如要高亮特别网络时，可以按住 CTRL 键并且点到该网

络。，点没对象的地方就会自动取消高亮了。持续这个操作。如果你的电路板在单层模

式， 你在布线网络检查筐中能使显示全部对象，来现示所有层的布线 

5.3. 现在重走这个版子使用你自订的对策，如 Figure99 中所示 

6.4. 首先，你需要清除所有的线段，你可以使用 Tools » Un-route 里面的选项来除线 

7.5. 复制这个预设 2 层板对策， 拖曳 More Vias slider 到最左边，勾选 Orthogonal 选项，并

且增加 Recorner 而且要在列表中 Straighten 的上面。 

6. 用你自订的对策执行自动布线 

7. 当你对于布线结果很满意，那就存盘吧。 
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      11.2.5    BGA Escape routing  BGA 扇出布线 
 

BGA 扇出布线的引擎主要是把线走到外围边界使你未来布线更容易 

 

 
Figure100.注意到扇出布线功能拉出每一个连结作为在BGA的边缘外边的一条可达到的路线的PAD。 

Figure100 显示的是 1mm 的 PAD 扇出布线。使用内部 PAD 先扇出然后使用传统狗骨头模式

(布线末端放置一个 via)  进入到另一层， 然后从过孔扇出到边缘。 

 

在 BGA 上点右键选 Component Actions » Fanout Component 菜单，就会依照设计规则做

扇出的动作。一个报告会自动产生和打开，显示没有扇处的管脚信息。 

报表会检查哪一些 PAD 没有扇出，在错误讯息对话框里面点选，就会跳到 PCB 相对应位置 

 



DAY2  完成 


